1. Sean Ogilvie
  2. PowerBuilder
  3. Wednesday, 27 July 2022 02:25 AM UTC

I can't open the 2019 R3 Powerbuilder IDE anymore.

I was running a process that appeared to hang, so I closed powerbuider (and the application process).

I tried to run PB 2019 R2, but it showed the splash screen, then dropped to the bottom, and I couldn't open it.

I set the ReopenWorkspace=0 and still no success.

I thought I had corrupted the PB IDE, so I downloaded and installed 2019 R3, with unfortunately the same result.

I read online that I might have some success by stopping the TabletInputService - 'Touch keyboard and handwriting panel' service. Unfortunately this did not fix it either.

Has anyone seen this? and/or can suggest a solution?


Attachments (2)
Sean Ogilvie Accepted Answer Pending Moderation
  1. Wednesday, 27 July 2022 20:29 PM UTC
  2. PowerBuilder
  3. # 1

Thanks Olan for your response.

This issue is now fixed. I did uninstall Powerberbuilder R2/R3, and re-install, and I now don't get the issue with the Powerbuilder IDE dropping to the taskbar, and becoming inactive.

The issue did continue when I just installed R3 over R2.

I didn't get to test a suggestion from Aubrey Lin to add ACCESSIBILITY=0 in pb.ini. So sorry that I can't verify if that works.

The issue of installing R3 had been made more difficult by my Security team that had Windows Defender stopping the installation, and it took much back and forth to get them to add exceptions that allowed a clean R3 install.

Feels good to be back productive again. Cheers

  1. Olan Knight
  2. Wednesday, 27 July 2022 20:55 PM UTC
Excellent news, thanks for sharing the solution! :)

If you would, please mark this issue as RESOLVED!


  1. Helpful 1
  1. Olan Knight
  2. Wednesday, 27 July 2022 22:40 PM UTC
Thanks, Sean!
  1. Helpful
There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Wednesday, 27 July 2022 14:00 PM UTC
  2. PowerBuilder
  3. # 2

Sean -

   When you downloaded and installed 2019R3 had you completeld UNINSTALLED R2? The two of them cannot coexist on the same platform.

   Try uninstalling R2 and R3, reboot the platform, check the Registry & the Program Fi les (x86) folders to ensure the APPEON components have been deleted, and then re-install R3.

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.