1. Marie Bisschoff
  2. PowerBuilder
  3. Friday, 3 April 2020 09:19 AM UTC

HI,

Can anybody tell me if I can do the following.

 

Use Powerbuilder 2017 with Oracle 12c client to Oracle 19c database.

 

Regards

ML

Attachments (1)
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Friday, 3 April 2020 21:34 PM UTC
  2. PowerBuilder
  3. # 1
1
Votes
Undo

Hi Marie,

Until now, I've never experienced any problems of using an older client version of Oracle with a newer Server Oracle version, as long as you don't use anything that wasn't supported in the "older" version. Oracle seems to be quite backwards compatible.

No guarantees, but ... why don't you just try? Maybe that's not possible right now for you, so sorry for my ignorance :)

 

Comment
HI Miguel,



No don't worry. If it was me reading the question, I would also see it like you understood it.

I appreciate your help.

This is forward compatible. Hope it workd.



Regards

ML
  1. Marie Bisschoff
  2. Monday, 6 April 2020 06:16 AM UTC
Hi, why not use the client of Oracle 19 instead of 12?
  1. Miguel Leeuwe
  2. Monday, 6 April 2020 07:54 AM UTC
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 3 April 2020 15:24 PM UTC
  2. PowerBuilder
  3. # 2
1
Votes
Undo

Hi Marie;

  Note: Using a mismatched client version compared to the DBMS Server is not recommended by either Oracle (or any DBMS vendor for that matter) or Appeon. So basically ... you would be "on your own support wise" (aka "use at own risk").

Regards ... Chris

Comment
HI,



Our DBA gave me the attachment I now added on my question. They say if I read the image right. that it is fine. I just don't know about Powerbuilder.



Regards

ML
  1. Marie Bisschoff
  2. Monday, 6 April 2020 06:22 AM UTC
Its not related to PB as all MW-Windows Apps that call the Oracle Client are at the execution & stability of that Oracle client version compared to the Oracle server version that they are talking to through that client. As I said before ... "Use at own risk". So if your DBA is forcing you to use a different client - then test, test, test ... etc. That is the only way to trust this mismatched software in any App IMHO.

=> A great question for an Oracle forum. ;-)
  1. Chris Pollach @Appeon
  2. Monday, 6 April 2020 19:20 PM UTC
Thanks for the help
  1. Marie Bisschoff
  2. Tuesday, 7 April 2020 11:11 AM UTC
There are no comments made yet.
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Friday, 3 April 2020 14:40 PM UTC
  2. PowerBuilder
  3. # 3
1
Votes
Undo

When you download the latest MR for PB 2017, there's a "....fixes.htm". At the top it says:

 

Appeon PowerBuilder 2017 R3 MR 1915 -- Fixes for 2017 R3 1880


PowerBuilder 2017 R3 MR 1915 supports the following new features:

  • Oracle 18c and 19c

 

regards

Comment
There are no comments made yet.
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Friday, 3 April 2020 12:40 PM UTC
  2. PowerBuilder
  3. # 4
0
Votes
Undo

Officially it should be supported if you have the latest MR for pb  2017 installed.

you have to use the "ORA" connection profile.

See this https://community.appeon.com/index.php/qna/q-a/pb-17-and-oracle-19c

 

Comment
HI



It talks about the Database 19c but nothing about doing it through Oracle 12c client



Regards

ML
  1. Marie Bisschoff
  2. Friday, 3 April 2020 13:31 PM UTC
Yes, I get what you've been saying, deleted my previous comment as not relevant.
  1. Miguel Leeuwe
  2. Friday, 3 April 2020 22:44 PM UTC
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.