1. Praveen Rajarao
  2. PowerBuilder
  3. Tuesday, 24 September 2019 13:57 PM UTC

Hi,

We are migrating our VDI desktops to Windows 10 and Office 365 (32 bit)

In our PB application, we are using MSMAPI control to retrieve outlook items and also send emails. 

With the current implementation, there is a popup that comes up asking user to give access to outlook for a specific amount of time. See Below:

But with Windows 10 using Office 365, the "Allow Access" checkbox is DISABLED. It doesn't allow for some reason. 

What is the work-around for this? Anyone seen this issue?

Thanks in Advance

Praveen

Who is viewing this page
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Wednesday, 25 September 2019 20:07 PM UTC
  2. PowerBuilder
  3. # 1

A part from what's been said, it's also important that your antivirus (windows defender, not sure about others) has to be "up to date" (updated). If not, whatever you do, that popup will still show up.

 

Comment
  1. Roland Smith
  2. Wednesday, 25 September 2019 21:03 PM UTC
This security message was added to Simple MAPI by Microsoft a long time ago, sometime while PB 6 was current if I remember correctly.
  1. Helpful
  1. Miguel Leeuwe
  2. Thursday, 26 September 2019 08:56 AM UTC
Yes, it's an old one. Though in "the beginning" your antivirus status did not seem to matter if I'm correct.

Now, your anti-virus also has to be up to date: Search for "Method 1" on this next page:



https://support.microsoft.com/en-za/help/3189806/a-program-is-trying-to-send-an-e-mail-message-on-your-behalf-warning-i



I would say that - in my experience - applying "Method 2: Change the Programmatic Access Security setting in Outlook" alone, is NOT enough. "Method 1: Enable or update your antivirus application" should ALSO be applied.
  1. Helpful
There are no comments made yet.
John Fauss Accepted Answer Pending Moderation
  1. Tuesday, 24 September 2019 16:11 PM UTC
  2. PowerBuilder
  3. # 2
Comment
There are no comments made yet.
Roland Smith Accepted Answer Pending Moderation
  1. Tuesday, 24 September 2019 14:08 PM UTC
  2. PowerBuilder
  3. # 3

You need to allow MAPI access to the mailbox from the Office365 management tool. I'm not sure how you do that but it is there somewhere.

Comment
  1. Praveen Rajarao
  2. Tuesday, 24 September 2019 14:25 PM UTC
Let me check that. Thanks.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.