1. John Murphy
  2. PowerBuilder
  3. Saturday, 10 March 2018 02:17 AM

I am testing using the  postgresql database and if I try to create a table it uses "user_name.table_name" but I need to create the tables in "public".  In other DB's i would just log in as "dbo" and all would be well but postgresql wont let me use public as a login.

Accepted Answer
mike S Accepted Answer Pending Moderation
  1. Saturday, 10 March 2018 15:14 PM
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

Postgresql uses schemas similar to how oracle does.

So what you could do is create a schema and user with the same name and use that instead of public.  Then it won't qualify the database objects with the schema name.

also, if you will use stored procedure based datawindows make sure you turn on the 'strip parameter names' option, otherwise parameters won't work with stored funtions.

 

Comment
there is also a setting in pbodb170.ini that you can add to the postgresql section:



PBTableOwner='NO'



If changing it doesn't work, then you updated only some of the ini files.  windows copies this to your local user settings directory.



It is a HUGE PITA to have to change this every time a new PB version comes out.  I wish appeon would add this to the ini file as part of the standard install.



  



 

  1. mike S
  2. Sunday, 11 March 2018 17:32 PM
I tried this before I posted. I searched the entire C: and found 3 real files, a bunch of shortcuts and two references that had no path???? I changed the 3 files but it did not fix it.

  1. John Murphy
  2. Sunday, 11 March 2018 23:36 PM
Hi all,



 



What Mike said is true. You can read more about this here: https://www.appeon.com/support/documents/appeon_online_help/pb2017r2/connecting_to_your_database/apas01.html



 



Mike,



I will pass your suggestion to our engineering team as an enhancement request. 



 



Regards,

  1. Govinda Lopez @Appeon
  2. Tuesday, 13 March 2018 18:12 PM
There are no comments made yet.


There are replies in this question but you are not allowed to view the replies from this question.