1. jeff hersey
  2. PowerBuilder
  3. Thursday, 20 September 2018

Windows 10

PB 2017 R3

Postgresql 9.6

ODBC Connection

 

-----

 

Hi,

When connecting to Postgresql, table names are not schema qualified.  PB assumes the user that I am connecting with, is the schema / owner of all tables.  

 

I have confirmed this by connecting with various postgresql user logins, and each time, PB will use the current user as the schema / table owner.

 

 

How can we get PB to schema qualify names.

 

Thanks!

 

Note:

We have been using PB (10, 11,12.5) with Postgresql for 10 yrs 

There are tables in two or more schemas with same name - dev is the logged in user.  There is no dev schema.

 

 

Accepted Answer
jeff hersey Accepted Answer Pending Moderation
0
Votes
Undo

Hi-

 

For those looking for the answer, the answer for me is in the pbodb170.ini flie - the one stored in my user profile's appdata folder ... not the ini files located in 4 other places on my workstation.

 

[PostgreSQL]
PBSyntax='PGSQL_SYNTAX'
PBDateTime='STANDARD_DATETIME'
PBFunctions='PG_FUNCTIONS'
PBDefaultValues='current_date,current_time,current_timestamp,current_user'
PBDefaultCreate='YES'
PBDefaultAlter='YES'
PBDefaultExpressions='YES'
DelimitIdentifier='NO'
PBQualifierIsOwner='NO'
PBSpecialDataTypes='PGSQL_SPECIALDATATYPES'
IdentifierQuoteChar='"'
PBTableOwner='YES'
PBCatalogOwner='public'
PBNoCatalog='NO'
ForeignKeyDeleteRule='Disallow if Dependent Rows Exist (RESTRICT),Delete any Dependent Rows (CASCADE),Set Dependent Columns to NULL (SET NULL)'

Comment
There are no comments made yet.
  1. Thursday, 20 September 2018
  2. PowerBuilder
  3. # Permalink
jeff hersey Accepted Answer Pending Moderation
0
Votes
Undo

adding more...

 

the procedures + functions are schema qualified

 

Comment
There are no comments made yet.
  1. Thursday, 20 September 2018
  2. PowerBuilder
  3. # 1
jeff hersey Accepted Answer Pending Moderation
0
Votes
Undo

Thanks Mike-

 

Unfortunately that does not solve the problem.

 

In 12.5, we are able to see all the tables schema qualified.  We have different schemas with the same table names.  For example, we have a deleted schema for all deleted records, and we have an archive schema that records archved records, and we have our application schema that has the active records.

 

PB 2017 is not schema or owner qualify the table names and changing the PBODB ini file does not seem to work.

 

Comment
There are no comments made yet.
  1. Thursday, 20 September 2018
  2. PowerBuilder
  3. # 2
mike S Accepted Answer Pending Moderation
0
Votes
Undo

system tab of the database profile setup has the setting for table owner.

Comment
There are no comments made yet.
  1. Thursday, 20 September 2018
  2. PowerBuilder
  3. # 3
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.