1. Angela Ohlberger
  2. PowerBuilder
  3. Wednesday, 09 January 2019

Hello All:

After migration from PB 12.5 Classics to PowerBuilder 2017 R3 we are facing an issue with the images and pictures.

All pictures on PictureButtons (assigned via PictureName) are visible in the appropriate objects. They are not visible when running the application in the development environment. Same for all other images or the splash window.

The pictures and images are all stored in the application path (as before in PB 12.5).

For deployment we are using a resource file and pictures and images are visible when running the executable.

It looks like the start path of the application in the development environment is missing. But I cannot find any system or application option to set the path. Actually Powerbuilder 2017 R3 should know it.

Or has anything changed in Powerbuilder 2017?

Does anyone know how the pictures and images can be displayed when running the application in the development environment.

Thanks in advance.

Angela

 

Who is viewing this page
Angela Ohlberger Accepted Answer Pending Moderation
0
Votes
Undo

What I have tested so far (without success). Running IDE still not showing the images/pictures:

 

1) Re-install Powerbuilder 2017 R3 on Windows 10

2) Install Powerbuilder 2017 R3 on Windows 7

3) Use Powerbuilder 12.5 on Windows 10 >> showing 98% of the images/pictures when running IDE

4) Using an application path on second level, C:\APPEON\APPs

5) Set System path to images/pictures

 

Next is to run processmonitor for further investigation ... or really report the issue to the ticket system.

 

Thanks for all the support so far

Angela

Comment
Hi Angela;

A small test App attached to a ticket might be the best for a faster answer.

Regards ... Chris
  1. Chris Pollach
  2. 6 days ago
There are no comments made yet.
  1. 6 days ago
  2. PowerBuilder
  3. # 1
Angela Ohlberger Accepted Answer Pending Moderation
0
Votes
Undo

Hi Chris,

Re-installing Powerbuilder 2017 R3 doesn't solve the issue.

Since PB is installed on Windows 10 I am checking hint of Brad regarding path length.

Regards

Angela

 

 

Comment
There are no comments made yet.
  1. 6 days ago
  2. PowerBuilder
  3. # 2
Mark Lee Accepted Answer Pending Moderation
0
Votes
Undo

Hi Angela,

I verified your issue.

I can display all the pictures and images on the Picture Button on PB 2017 R3.

But we found that the length of the path can’t be too long on both PB 12.6 and PB 2017 R3 in Window 10. It appears that it is invalid when the folder hierarchy is more than three level.

 

Suggestion:

  1. Please verify your application path is set correctly. Note: don’t set to a path under WOW6432Node node.
  2. Please restart your machine and verify the application path is indeed written to the registry.

Each time you change the setting, please close all PB IDE and then restart to verify.

If you still have the issue, kindly please report this problem to our ticket system: https://www.appeon.com/standardsupport/ so we can properly receive and track things. Please also provide a PB test case when you submit it to the ticket system.

Regards,

Mark Lee

Comment
There are no comments made yet.
  1. 6 days ago
  2. PowerBuilder
  3. # 3
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Angela;

  FWIW: You are the 1st person whom I have seen comment on this. Sounds like your PB IDE installation may not have completed 100% or your IDE registry entries did not get done. I have many such Apps with images within or outside the PB App workspace area (folder). They are all are displaying their images / icons properly (in all releases of PB 2017Rx.

  Have you tried re-installing PB 2017?

Regards ... Chris

Comment
There are no comments made yet.
  1. one week ago
  2. PowerBuilder
  3. # 4
Julia Seytter Accepted Answer Pending Moderation
0
Votes
Undo

We have never used the path for images as they are stored in the application folder where all the PBL's are in. And it worked fine for Powerbuilder 12.5.

And now with Powerbuilder 2017 R3 when running app from IDE it doesn't work. It also doesn't work for the Powerbuilder implemented images, e.g. CheckStatus!

I have tried to add the application path to the system path but even that doesn't help.

 

 

Comment
There are no comments made yet.
  1. one week ago
  2. PowerBuilder
  3. # 5
Brad Mettee Accepted Answer Pending Moderation
0
Votes
Undo

We have always put the path for the images in the system path. That way they're available for the IDE, when running app from the IDE, and during compiles. We keep a repository of images for all of our app development on a network drive. 

Where are the files actually located? If they're in the same folder as the PBLs, running from the IDE should work fine (unless your app changes the default directory before anything is displayed).

Do any of your images have full path defined in them?

You can find out if adding to the system path will help by doing this:

Open CMD prompt
path %path%; (don't use quotes even if it has spaces in it)
start pb170.exe

Try running from IDE. If it works, edit the system environment and add your images location to the path. Then close/re-run PB again and it should all work fine.

Comment
There are no comments made yet.
  1. one week ago
  2. PowerBuilder
  3. # 6
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.