1. Susana Domingos
  2. PowerBuilder
  3. Wednesday, 21 August 2019

Using PowerBuilder 19 and standalone compiler PBC190. All works as expected in PowerBuilder 19.

When using PBC190, the creation of the dll's failes.
Elevated Commandline is:
pbc190.exe /d "E:\_troubleshoot\Ada\ada.pbt" /o "E:\_troubleshoot\Ada\ada.exe" /r "E:\_troubleshoot\Ada\ada.pbr" /w n /f /m y /tr n /in y /op 0 /x 32 /bg y /p "ADA" /cp "Falck Emergency IT" /de "ADA" /cr "Falck Emergency IT" /v "1.0.0.1" /vn "1.0.0.1" /fv "1.0.0.1" /fvn "1.0.0.1" /ge 0

One of the logfiles is as follows - all logfiles have the same last 8-line pattern:
CGEN: Compiling 'C:\Users\\AppData\Local\Temp\DN32T.c'
C:\Users\\AppData\Local\Temp\DN32T.h(1) definition of macro 'PS_UNICODE' not identical to previous definition
C:\Users\\AppData\Local\Temp\DN32T.h(1) included from C:\Users\\AppData\Local\Temp\DN32T.c(4)
C:\Users\\AppData\Local\Temp\DN32T.h(1) macro 'PS_UNICODE' defined on the command line
C:\Users\\AppData\Local\Temp\DN32T.h(5828) definition of macro 'SUCCEEDED' not identical to previous definition
C:\Users\\AppData\Local\Temp\DN32T.h(5828) macro 'SUCCEEDED' defined in: C:\Program Files (x86)\Appeon\AutoCompiler 19.0\cgen\h\strsafe.h(40) (col 9)
C:\Users\\AppData\Local\Temp\DN32T.h(5829) definition of macro 'FAILED' not identical to previous definition
C:\Users\\AppData\Local\Temp\DN32T.h(5829) macro 'FAILED' defined in: C:\Program Files (x86)\Appeon\AutoCompiler 19.0\cgen\h\strsafe.h(44) (col 9)
C:\Users\\AppData\Local\Temp\DN32T.h(53744) '//' style comment continues on next line
C:\Users\\AppData\Local\Temp\DN32T.h(53745) '//' style comment continues on next line
C:\Users\\AppData\Local\Temp\DN32T.h(53746) '//' style comment continues on next line
C:\Users\\AppData\Local\Temp\DN32T.h(53747) '//' style comment continues on next line
C:\Users\\AppData\Local\Temp\DN32T.h(53748) '//' style comment continues on next line
C:\Users\\AppData\Local\Temp\DN32T.h(69484) nested comment found in comment started on line 69483
CGEN: Compiling 'C:\Users\\AppData\Local\Temp\ada.c'
CGEN: Compiling 'C:\Users\\AppData\Local\Temp\cgpwkurp.c'
CGEN: Linking...
CGEN: Resource compiling 'C:\Users\\AppData\Local\Temp\ada.rc'
WATCOM Windows Resource Compiler Version 11.0
Copyright by Sybase, Inc., and its subsidiaries, 1993, 1997.
All rights reserved. Watcom is a trademark of Sybase, Inc.
C:\Users\\AppData\Local\Temp\ada.rc(33) Error! 36: '$' is not valid at this point
C:\Users\\AppData\Local\Temp\ada.rc(34) Error! 36: '$' is not valid at this point
C:\Users\\AppData\Local\Temp\ada.rc(54) Error! 49: Syntax error near "end"

 

What's causing this?

Accepted Answer
René Ullrich Accepted Answer Pending Moderation
0
Votes
Undo

Hi Susana,

Are your sure that it is not the $ from your command line ("$(version.number)") that causes the problem?

Comment
I updated my question with the correct command.



Thank you René, and _sorry_, I had copied that from a build pipeline and not from the actual command line I'm running it from (facepalm).

  1. Susana Domingos
  2. Wednesday, 21 August 2019
And thank you again, you pointed me in the right direction - I had a leading 0 (zero) in one of my version numbers. In this post someone had already identified that as a PBC issue: https://community.appeon.com/index.php/qna/q-a/autocompiler-fails-with-executable-link-error
  1. Susana Domingos
  2. Wednesday, 21 August 2019
There are no comments made yet.
  1. Wednesday, 21 August 2019
  2. PowerBuilder
  3. # Permalink


There are replies in this question but you are not allowed to view the replies from this question.