1. Simone Olianti
  2. PowerBuilder
  3. Friday, 20 April 2018 16:30 PM UTC

Hi there pb fellows... I am testing the autocompile utility (Appeon PB 2017 R2). Everything worked like a charm, and i was able to put the script as a planned operation without troubles.

My question is: is it normal that the utility is very slow compared to the standard compilation launched from the IDE? I made a full rebuild with debug symbol disabled and generating 32 bit Pcode. From the ide usually takes about 40 mins to compile my project, but from pbc it took more than 4 hours.
tia,
  simone

Accepted Answer
Tom Jiang @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 24 April 2018 09:13 AM UTC
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

Hi Simone,

PBC170 is a small compiler than the full-blown PB IDE. It is normal if there is some performance difference between the two. But the difference in your case seems to be rather large. If you can provide a sample project code that can duplicate the issue, I suggest that you open a support ticket for your case.   

Regards, 

​Tom Jiang

Comment
i guess i finally found what was wrong.. it was a machine problem in my case. I tried to launch the autocompiler on another machine and it took almost the same time as the ide compiler

  1. Simone Olianti
  2. Tuesday, 24 April 2018 14:54 PM UTC
There are no comments made yet.
Tareq Haschemi Accepted Answer Pending Moderation
  1. Monday, 23 April 2018 14:19 PM UTC
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi there, I have also observed this. via the IDE we compile in 5 minutes, via autocompile pbc170 we need 20 minutes.

This is also very slow for us.

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.