1. Krishna Mohan Gullap
  2. PowerBuilder
  3. Tuesday, 26 October 2021 19:00 PM UTC

Hello to all PowerBuilder guru's here

I am here again with one more weird PowerBuilder issue as I always do :-)

I have an application on PowerBuilder 11.X which connects to a DB2 DSN (say DB2TEST) without any issues

I migrated this app to PB 2019 and it won't connect to that DSN anymore though DB2TEST is there (same environment used for testing both the versions). Here are the steps I followed

1. Installed the application build from Production

2. Replaced all the PBDs and the application EXE

3. Edited the <application-name>.xml file that PB 2019 generates as part of the build, to point to the application installation folder itself

4. Copied all the PB 2019 run time files to the application folder. So, now, the PBD, EXE, and DLL are all in one place and the XML points to this folder as well (Looks like all is well)

5. Run the PB app. It opens fine. Good until here !

6. Login using the same user id and pwd as the one used in the PB 11.1 version of application build. The login fails with the message 'Data Source Name not found and no default driver specified'. The DSN which is used to connect (DB2TEST) is there and the PB 11.X version build connects to the same DSN just fine (Verified this by popping up a message box with the DB parm parameter for SQLCA, returns the same value for both 11.X and 2019 PB builds of the application. The PB 11.x build connects to the DSN and opens up the main screen, while the 2019 version stalls there with this error


May be I don't know if Appeon changed something w.r.to ODBC/DB2? Do I have to look at the PBODB.INI? I have no clue and can't move forward


In desperate need of help please :-)




Olan Knight Accepted Answer Pending Moderation
  1. Tuesday, 26 October 2021 21:25 PM UTC
  2. PowerBuilder
  3. # 1

With PB2019R3, the runtime DLLs have been separated from the IDE DLLs, and there are new ODBC DLLs as well.

For me, I run the following files with my applications.
 - Note the two INI files at the end of the list.


Start with this list of runtime DLLs. If you need to add other files, you can do so easily.

There are no comments made yet.
Krishna Mohan Gullap Accepted Answer Pending Moderation
  1. Wednesday, 27 October 2021 12:52 PM UTC
  2. PowerBuilder
  3. # 2

Actually the problem was with the bit configuration of the DSN installed on the machine. This is a VDI machine which is on Citrix

The DSN which shows up is actually a 32-bit DSN, but this was being displayed in the 64 bit ODBC administration as well under 'System DSN'

I had built my application on 64-bit since I had thought the DSN is also a 64-bit and the Windows OS is a 64-bit OS as well

But, a simple deployment of code on 32-bit solved the issue. Pheww !!


Now, after getting the application to work, I am running into another problem. The DB2 RPC calls don't seem to work anymore. Troubleshooting this problem right now

PowerBuilder application execution error (R0007)
Application terminated.

Error: Database Interface does not support Remote Procedure Calls




  1. Armeen Mazda @Appeon
  2. Wednesday, 27 October 2021 15:57 PM UTC
Hi Krishna, Please post different issue as separate question please. Glad to hear the original issue is resolved, and we appreciate that you explained what the problem was and how you resolved!
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.