1. Antonin Krejci
  2. PowerBuilder
  3. Thursday, 14 May 2020 13:39 PM UTC


I would like to ask about the PB Oracle DB driver

We have PB2017R2 (1756) & Oracle client 11.2 and DB Oracle 11.2

with migration to Oracle DB 19 I face issue where the Timestamps are  handled as dates instead of Timestamps and because of that any update of DW involving timestamp column is failing as the seconds fractional part is not there


Even forcing the DBPArm to TimeStamp=1 (which should be default) is not changing the behaivour

Do you have similar issues?

Is there a way how to force the Timestamp handling (other than via DBPArm)

--Example from trace

same application from same place just connected to different DBs

Ora 11

(05908028): UPDATE "CERT" SET "LST_UPD_TMSTMP" = TO_TIMESTAMP('13-05-2020 20:29:24.417000','DD-MM-YYYY HH24:MI:SS.FF')


Ora19 (same settings)

(05908C30): UPDATE "CERT" SET "LST_UPD_TMSTMP" = TO_DATE('13-05-2020 20:26:36','DD-MM-YYYY HH24:MI:SS)



Who is viewing this page
Antonin Krejci Accepted Answer Pending Moderation
  1. Saturday, 16 May 2020 05:29 AM UTC
  2. PowerBuilder
  3. # 1

Tried with PB2019R2, Oracle Client 11 and Oracle DB 19 and the timestamps are correctly handled


UPDATE CERT SET "LST_UPD_TMSTMP" = TO_TIMESTAMP('15-05-2020 13:28:33.274000','DD-MM-YYYY HH24:MI:SS.FF'),

  1. Armeen Mazda @Appeon
  2. Saturday, 16 May 2020 13:11 PM UTC
Glad to hear problem solved with latest version!
  1. Helpful
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Thursday, 14 May 2020 15:46 PM UTC
  2. PowerBuilder
  3. # 2

PowerBuilder 2017 R2 does not support Oracle 19C.  It was officially supported in PowerBuilder 2019 R2, and we also supported additional Oracle data types.  Please test with PowerBuilder 2019 R2 and using PBORA190.dll. If your issue still persists, please open a support ticket with your test case.  Thanks!

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.