1. Jon Jaroska
  2. PowerBuilder
  3. Thursday, 8 March 2018 11:31 AM

I have just installed the trial of pb 2017 and the new pfc 2017.  My application fails with the following error when going through the pfc security routine.  Shown below that is the sql from the d_pfccontrollist.  Is window now a reserved word?  It fails in the painter as well but if I copy the sql to mgmt studio, there is no problem and it works fine.

Incorrect syntax near 'window'

SELECT security_info.window
     , security_info.control
     , security_info.status
     , security_users.priority
FROM security_info
   , security_users
WHERE(security_users.name = security_info.user_name)
     AND ("security_info"."window" = 'w_gr_frame')
     AND ("security_info"."user_name" = 'xyzuser')
     AND ("security_info"."application" = 'inv')
          ORDER BY security_info.control ASC
                 , security_users.priority ASC

Accepted Answer
Matthew Balent Accepted Answer Pending Moderation
  1. Thursday, 8 March 2018 18:43 PM
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

What is your 'quoted identifier' option on your db profile?

Comment
Ok.  That worked.  I added DelimitIdentifier=1 into the DbParm.  Thank you.

  1. Jon Jaroska
  2. Thursday, 8 March 2018 19:07 PM
There are no comments made yet.
Arthur Hefti Accepted Answer Pending Moderation
  1. Thursday, 8 March 2018 12:39 PM
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi

it looks like you run the SQL against an SQL Anywhere Database, maybe a newer version of the engine that you used to have. Window is a reserved word in SQL Anywhere since a couple of versions. You need to put it i quotes.

Regards
Arthur

Comment
this is the stock datawindow object in the pfc libraries executing against the same microsoft sql server that i have had.  so i don't think it is the database.  it has to be something with the pfc library or the way the connections to the database work in pb 2017, right?

  1. Jon Jaroska
  2. Thursday, 8 March 2018 17:38 PM
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.