1. Mathieu Normandeau
  2. PowerBuilder
  3. Wednesday, 26 September 2018

Hi,

We converted our code from Powebuilder 12 to Powerbuilder 2017 R3 and use Git as Source Control.

With Powerbuilder 12, Orca script didn't work for our project because we have some complex dependancy in the project.

With the version 2017 R3, the option "3-pass" should fix this kind of problem, but I may not understand it well.

When I try to rebuild the .pbl with orca script, I get some dependancy error:

Here is my orca script:

start session
scc set connect property localprojpath ".\.."
scc set connect property logfile  "orca.log"
scc set connect property logappend false
scc set connect property deletetempfiles "true"
scc connect offline
scc set target "inmopp01.pbt" "refresh_all" "importonly"
scc exclude liblist "..\emowpv01\in_ws_hp_exstream.pbd" "..\references\externe\pbwsclient170.pbd" "..\in_maj_web_optimise\in_maj_weboptimise.pbd"
scc refresh target "3pass"
scc close
end session

 

Here is how i call it:

Orcascr170.exe /D refresh_flags="outofdate exclude_checkout" /D build_type="3pass"  buildorca.dat

 

when the refresh is done, I get some error of dependancy with object in the "Exclude liblist"

If i don't exclude the liblist, I get that kind of error:

Unable to process map file: d:\gitrepos\disability.tide\references\externe\pbwsclient170.pbg
d:\gitrepos\disability.tide\references\externe\pbwsclient170.pbd cannot be refreshed.

 

Any idea?

 

Thanks in advance

 

 

 

 

Accepted Answer
Mathieu Normandeau Accepted Answer Pending Moderation
0
Votes
Undo

PBD must be in the directory of the target

Comment
There are no comments made yet.
  1. Tuesday, 9 October 2018
  2. PowerBuilder
  3. # Permalink


There are replies in this question but you are not allowed to view the replies from this question.