1. Kwadwo Boahene
  2. PowerBuilder
  3. Thursday, 24 August 2017 14:51 PM UTC

I successfully migrated (trial)  PB 12.1 to Powerbuilder 2017 but my email which I send through SMTP (local) is not working. One of the errors I get is "An attempt was made to access a socket in a way forbidden by its permissions". My suspicion is the localhost port is being used by something else or blocked. I installed the trial version on a local machine and on a server and they have the same problem whether running the app in Powerbuilder  or the compiled version. My local machine also has a the version 12.1 and that has the same problem now which it didn't have before install PB 2017. Any suggestions?



Kwadwo Boahene

Roland Smith Accepted Answer Pending Moderation
  1. Thursday, 24 August 2017 15:01 PM UTC
  2. PowerBuilder
  3. # 1

The built-in email is MAPI, what method are you using to send via SMTP?

Are you running from the IDE or an EXE? If EXE, is it 32bit or 64bit?


  1. Kwadwo Boahene
  2. Friday, 25 August 2017 14:27 PM UTC
Thanks. It was actually the SMTP setup on our new development environment that was wrong. After I ran your program and got the same error I drew ops attention to that fact and after some testing we found the problem and fixed it and the program worked fine afterwards.

  1. Helpful
  1. Rajesh Selvam
  2. Thursday, 23 November 2017 17:34 PM UTC
Hi, I get the same error 'an attempt was made to access a socket in a way forbidden by its access permissions' when I run 64 bit exe. 32 bit exe works just fine. What SMTP setup was changed to fix your problem? Thanks!

  1. Helpful
  1. Marie Bisschoff
  2. Monday, 11 December 2017 11:48 AM UTC

We run both SMTP and MAPI.

Does anything change on SMTP?



  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.