1. Sivaprakash BKR
  2. PowerBuilder
  3. Wednesday, 7 July 2021 06:49 AM UTC

Hello,

PB 10.5 Application in Windows 7 SP1   -> Works fine.

PB 10.5 Application in Windows 10 -> Running from IDE, when application closes PB (IDE) also closes.

PB 10.5 Application Migrated to PB 11.5 in Windows 10 -> Running from IDE, when application closes PB (IDE) also closes.

PB 10.5 Application Migrated to PB 2019 R3 in Windows 10 -> Running from IDE when application closes PB (IDE) also closes.

I could see the messagebox, till the last line in the application close event.  

What could be the issue ?  What to check ?  Any ideas ?

Happiness Always
BKR Sivaprakash

 

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 7 July 2021 21:43 PM UTC
  2. PowerBuilder
  3. # 1

Hi Olan et Al;

  FWIW:  Sivaprakash is not complaining that he cannot install and then run the respective IDE's on W10. He is just relaying that when he runs his App from the respective 11.5 or 2019R3 IDE that both IDE's will close right after his App closes - trying to return to the respective IDE (on W10).

Regards ... Chris

Comment
  1. Sivaprakash BKR
  2. Thursday, 8 July 2021 07:54 AM UTC
Yes Chris.

app works fine when app is in Win 7 Machine and run from either Win 7 / Win 10 machine.

IDE closes when app is in Win 10 machine and run from Win 10 machine.



My win 7 machine is ageing, and I just transferred all files to a newer system, which is Win 10, and tried to run from there. Not all apps has this issue, only fewer. Trying to find out what differences are there between those apps. All apps developed between 2000 - 2008 in PB 10.5 / PB 11.5.

  1. Helpful
  1. Chris Pollach @Appeon
  2. Thursday, 8 July 2021 14:15 PM UTC
I suspect that running from the PB 12.6 IDE as well will have this issue if also in PB11.5 as PB 2017 and higher releases are built upon the PB 12.6 code line that SAP gave Appeon. I wonder if your App is using some MS-Window;s API(s) that are corrupting memory somehow in W10 (but W7 was not affected)?
  1. Helpful
  1. Sivaprakash BKR
  2. Friday, 9 July 2021 07:54 AM UTC
We are analysing the code. When we run the application, the first screen, which is login screen, gets opened. Without doing anything even clicking the Exit button makes the IDE to close. Before opening the login screen, a call to the following function is there, which doesn't have option for 64 bit windows. We suspect it may be a reason!



*******************************************************

--- f_create_external_function(auo_extension)

string ls_wintype = "u_external_function"

choose case ge_environment.ostype

case sol2!

ls_wintype = ls_wintype + "_sol2"

case hpux!

ls_wintype = ls_wintype + "_hpux"

case aix!

ls_wintype = ls_wintype + "_aix"

case macintosh!

ls_wintype = ls_wintype + "_mac"

case else

if ge_Environment.Win16 then

ls_wintype = ls_wintype + "_win16"

else

ls_wintype = ls_wintype + "_win32"

end if

end choose

auo_extension = create using ls_wintype

if IsNull(auo_extension) then

return false

else

return true

end if

*****************************************************************

We plan to rewrite this part in this week end or beginning of next week and check.

  1. Helpful
There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Wednesday, 7 July 2021 20:38 PM UTC
  2. PowerBuilder
  3. # 2

Is SYSAM running correctly on the PBv10.5 environments?

 

Comment
  1. Armeen Mazda @Appeon
  2. Wednesday, 7 July 2021 21:07 PM UTC
Unless my memory is failing me, I don't believe version 10.5 had SySAM. Sybase introduced that in version 11.0 until version 12.6.
  1. Helpful
  1. Chris Pollach @Appeon
  2. Wednesday, 7 July 2021 21:10 PM UTC
Correct
  1. Helpful
  1. Olan Knight
  2. Wednesday, 7 July 2021 21:24 PM UTC
Right! I'm on version 12.1, not 10.5.

DOH! :O

  1. Helpful
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 7 July 2021 07:06 AM UTC
  2. PowerBuilder
  3. # 3

If you can provide your app source code to us, I suggest you open a ticket and attach your source code so we can reproduce this issue and troubleshot.  It is most likely a bug in PB or a corrupted file in your app.

Comment
  1. Sivaprakash BKR
  2. Wednesday, 7 July 2021 11:50 AM UTC
Thanks, Armeen,

WIll create a ticket with our source code soon.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.