1. Dennis Little
  2. PowerBuilder
  3. Friday, 8 September 2017 16:45 PM UTC

Greetings All,

Previously posted this about a month ago.

We recently upgraded to PB2017 from PB12.6.  We are having issues with pbnismtp.
I created a new library and imported the pbnismtp126.pbx file and compiled a pbd.  I added the new pbd and the pbx file to the working directory of the application.
Works in IDE, not in EXE.  We also added the crucial PB17 dlls to the start folder.

We get a bad runtime reference error when it gets to this line: l_smtp.SetRecipientEmail(ls_ToMail)
I am running the EXE on a different machine-it mimics the PRODUCTION runtime environment.

We’re running on a 32 bit platform.

It worked great in PB12.6, we're probably missing a dll or two for PB17, any ideas?

BTW - We tried the Dependency Walker- didn’t seem to help.  

Thanks

Dennis

Accepted Answer
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 8 September 2017 18:28 PM UTC
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

Hi Dennis;

   The PBNISMTP object is not from Appeon. You would have to contact the author - a Mr Bruce Armstrong on GitHub - to see if he can guide you through the migration of his object into PB 2017.

HTH

Regards ... Chris

Comment
There are no comments made yet.
Roland Smith Accepted Answer Pending Moderation
  1. Monday, 11 September 2017 12:07 PM UTC
  2. PowerBuilder
  3. # 1
0
Votes
Undo

I created an updated version that is PB version independent and has a 64-bit version of the .pbx file. You can download from here:

http://www.topwizprogramming.com/pbnismtp.html

 

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.