1. Olaf Brungot
  2. PowerBuilder
  3. Tuesday, 8 September 2020 06:59 AM UTC

This issue is found in Version 2019 R2 Build 2353.

There is a difference between the pbt library list and the build option library list.

I get the warning: The current library list is different from the library list contained within this project. The project library has been updated. Refresh build options for the changed list and try again.

The library list (from target) is correct, but there are missing libraries in the build list. How do I refresh the build options?

Library List ok.

Build options, not ok.


Accepted Answer
Olaf Brungot Accepted Answer Pending Moderation
  1. Thursday, 10 September 2020 10:39 AM UTC
  2. PowerBuilder
  3. # Permalink

None of the suggestions worked.


Export object -> Edit source manually -> Import object -> Resolved.

  1. Chris Pollach @Appeon
  2. Thursday, 10 September 2020 17:46 PM UTC
Glad that workaround worked for you! :-)
  1. Helpful
  1. Armeen Mazda @Appeon
  2. Monday, 21 September 2020 17:18 PM UTC
Thanks for sharing the solution!
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 8 September 2020 20:38 PM UTC
  2. PowerBuilder
  3. # 1

Hi Olaf;

  After changing the library list in the target & saving the changes - open the Project object and try to perform a build in the project painter. The project object should then come back with a message "the library list has changed". Once that happens, you should now see the corrected libraries in the project's library list as per the target object. Check the library options and then save the updated project. It should deploy OK now.

Regards ... Chris

There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Tuesday, 8 September 2020 14:16 PM UTC
  2. PowerBuilder
  3. # 2

Go ahead and SAVE the project file.
When you re-open it, the file should be updated with the contents of the LIBRARY list.


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.