1. Ramendra Singh
  2. PowerBuilder
  3. Monday, 24 September 2018

Hi Gurus 

I am using Git (Bitbucket) for source control and configured the Git in PB 2017 R3 as per the steps provided in the help file. The connection works fine and mapping is also fine (able to do the SCM activities using GIT). 

There are random issues I noticed while try to PUSH,PULL and COMMIT using PB IDE. In short,it never worked for me and still doing these activities through Sourcetree IDE.

PULL don't recognize mapping.  - I don't remember/reproduce the  the error as I am getting some other error now.

PUSH throws below error 

--------- Source Control
Git push
Starting to push workspace...
Git client is pushing workspace. Please wait...
Git client error code: Reference was not fast-forwardable.
Failed to push workspace.
Git push completed.
---------- Done Source Control

 

But now, I am also getting a warning "Cannot open the working copy due to Git version incompatibility" 

I am using GIT 2.18.0.

Please let me know if there is any other questions.

Regards

Ramendra 

 

 

Christopher Moran Accepted Answer Pending Moderation
0
Votes
Undo

I never could get PB to work with Git due to 1. repo name has to match your workspace name and 2. branches in git are not supported yet, they tell us to use a third party program which is all well and good but if your company doesn't allow this other program you're out of luck imo. If you have any insight from your trials please share.

Comment
I think your first issue about repo name has been resolved in 2017 R3. If feasible, please test and let us know.



The third-party program is TortoiseGit, which is widely popular. Your company really won't allow you to install this particular software?
  1. Armeen Mazda
  2. Tuesday, 25 September 2018
There are no comments made yet.
  1. Tuesday, 25 September 2018
  2. PowerBuilder
  3. # 1
Ramendra Singh Accepted Answer Pending Moderation
0
Votes
Undo

Hi All

Although "Cannot open the working copy due to Git version incompatibility" is resolved by deleting everything from repository and getting a latest copy of source from GIT but other problems are still the same.

PUSH - always return Git client error code: Reference was not fast-forwardable.

PULL - don't pull the committed object from git.

COMMIT  - works only within PB but due to PUSH failure, manual commit is the only option currently.

 

Thanks

Ramendra 

 

 

 

 

 

 

 

Comment
Hi,



The push error you got indicates that the server contains commits that are not in your local repository. The pull didn't work, it could be that the changes on the server conflict with the changes on your local repository. You will need to review the objects in conflict (marked with a ! sign) and make appropriate modifications and then do a Git Resolve. After everything is sorted out, do a final commit and it should allow you to push to the server now.



BTW, when you first connect to the workspace from a new location, please do a Refresh before editing any code.



Regards,



Tom Jiang
  1. Tom Jiang
  2. Wednesday, 26 September 2018
There are no comments made yet.
  1. Monday, 24 September 2018
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.