1. Andreas Mykonios
  2. PowerServer 2020 or older (Obsolete)
  3. Friday, 18 March 2022 11:42 AM UTC


We had an old powerserver (Appeon for Powerbuilder v.2015) installed in a client. They had an web application running.

Recently we decided to upgrade to PowerServer 2020. Everything went ok. We then redeployed the application using Powerbuilder CloudPro 2019R3 (ebf. 2670). After deployment, we ran an issue where some clients pc, after xcelerator pugin instalation, the app fails to run. It shows the following message:

Web browser ends up showing an error that there was a problem with xcelerator plugin installation.

Has anyone faced this issue? What are your recommendations to fix it?



Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Monday, 21 March 2022 01:02 AM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 1

Hi Andreas,

Generally Appeon plugin will be upgraded automatically. How did you deploy the application, using Toolkit or application package? Please note that it is reuquired to full deploy application after PowerServer upgraded.

This issue might case by the PowerServer version and application deployed version are difference, please check and make sure they are the same:

1. The PowerServer version.
You can check it from the AEM login page.

2. The application deployed version.
%webserver%/%application%/x32_application.html has line like below.

Please try to Full Deploy the application to PowerServer again. It’s suggested to deploy the application with Toolkit or install the application using server deployment project package because directly copying application files could easily cause problems. Below is the introduction on using Toolkit to deploy application for your reference:

If the issue is still there, please refer to the article below to remove the plugin and run the application again to see if it works.


Andreas Mykonios Accepted Answer Pending Moderation
  1. Friday, 18 March 2022 15:53 PM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 2

Hi Marco.

Thank you for answering.

Thats what I see in control panel:

Actually we did not upgrade. Appeon support recommended uninstalling Appeon for Powerbuilder 2015. After we did a new installation of PowerServer.

The application was deployed using PowerBuilder 2019R3 (I believe the runtime was set to 2670). I guess that for points 1 & 2 we are ok.

As for point 3, we did try to install the plugin using the url you provided. But I tried to copy the installation file from iis corresponding folder and run it to the machine. I will try using the url you provided.

We did removed the old xcelerator plugin. We also found and clean contents from C:\Users\<user profile>\AppData\Local\Appeon Multi-browser Plug-in as we found that after uninstall there was some content remaining in these folder. I don't know if the installation for the plugin places files in any other folder.

But no chance.


There are no comments made yet.
Marco Meoni Accepted Answer Pending Moderation
  1. Friday, 18 March 2022 14:39 PM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 3

Hello Andreas,

1) did you upgrade PS 2020 on the server machine? You must see PS 2020 for .NET build 12.0.2### in the Control Panel

2) upgrade of PB to 2019 R3 is necessary to have PS deployment toolkit compatible with PS installed at 1)

3) now you can upgrade the weblibrary installed at the client, PS 2020 delivers the crossbrowser plugin (available at http://server/appeon/weblibrary_ax/crossbrowser/appeonbrowser.exe). After you do so, you must find installed on the client Control Panel the "Appeon Multi-browser" Plugin

4) you may need to remove the old Xcelerator plugin #0328 if it is still found

Here the hoot:

1) for the server: https://docs.appeon.com/ps2020/installation_guide/Appeon_Server_installation_net.html

2) for the client: https://docs.appeon.com/ps2020/installation_guide/NET_Configuration_for_client_machine.html




There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 18 March 2022 14:35 PM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 4

Hi Andreas;

  Looks like the Appeon Web Web Browser plug-in installation failed for some reason. So when the App started it checked the current plug-in (which as not 2020 compliant) and thus failed - resulting in that message.You will need to investigate why the newer WB plug-in installation failed. It could be because the App user did not have Local Admin privileges to install the plug-in into the current WB.

Note: Appeon provides the WB plug-in install EXE. You might have to use that on the App user's machine to get the latest WB installed by your operations team.

Regards ... Chris

  1. Andreas Mykonios
  2. Friday, 18 March 2022 15:55 PM UTC
Thank you Chriss.

I did tried to install it from the exe, but it's still not running. Also I do not believe that the user doing the installation had not enough privilleges, but I will invstigate that.

  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.