1. ATK Gimmy Susan
  2. SnapObjects
  3. Tuesday, 16 July 2019

Hi Guru.

I am publishing a Webservice written with Snapobject on IIS in my local machine and I have the following error:

 



How I worked:

1)  As indicated on: https://www.appeon.com/support/documents/appeon_online_help/snapdevelop2019/web_deploy/index.html I posted the ws on a folder.

2) I created a new application in my IIS (as in the image)

 

3) i run: http://localhost/WebApp

 

 

 

Where is my mistake?

thank for answers

 

Gimmy

 

Ps:

- Windows 10

- IIS v10.0.17134.1

 

Logan Liu Accepted Answer Pending Moderation
0
Votes
Undo

Hi Gimmy,

Please make sure that the Application Pool > Process Model > Identity is set to ApplicationPoolIdentity or the custom identity has the correct permissions to access the app's deployment folder.

Refer to Troubleshooting > 3. Issues concerning IIS application pool permission in 

https://www.appeon.com/support/documents/appeon_online_help/snapdevelop2019/web_deploy/index.html

 

You can also refer to the document of ASP.NET Core for more details about the error 500.19:

https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/azure-iis-errors-reference?view=aspnetcore-2.1

Or the similar question on stackoverflow:

https://stackoverflow.com/questions/40805402/http-error-500-19-when-publish-net-core-project-into-iis

 

Regards,

Logan

Comment
i try, both

1) The configuration mask is different. =(

2) I tried to put 'stdoutLogEnabled = false'



unfortunately nothing changes
  1. ATK Gimmy Susan
  2. Wednesday, 17 July 2019
This problem occurs because the the Web.config file contains a malformed XML element. You should delete the malformed XML element from the Web.config file.



Refer to 0x8007000d in:

https://support.microsoft.com/en-us/help/942055/http-error-500-19-error-when-you-open-an-iis-7-0-webpage



There are more solutions about 0x8007000d :

https://stackoverflow.com/questions/16836473/asp-net-http-error-500-19-internal-server-error-0x8007000d
  1. Logan Liu
  2. Thursday, 18 July 2019
Have you installed all requirements for server side?

E.g.: Runtime & Hosting Bundle

Download link for Runtime & Hosting Bundle: https://dotnet.microsoft.com/download/dotnet-core/2.1 (Runtime 2.1.* | Windows | ASP.NET Core/.NET Core: Runtime & Hosting Bundle)
  1. Logan Liu
  2. Thursday, 18 July 2019
There are no comments made yet.
  1. Wednesday, 17 July 2019
  2. SnapObjects
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.