1. Jonas Blomgren
  2. PowerServer Mobile
  3. Wednesday, 06 September 2017

Hello
Testing the mobile powerserver on win 2012 R2 and iis and found a problem

I need to deploy all PB mobile apps to a common subfolder, eg http://myserver.com/PBMobile/Myapp1, http://myserver.com/PBMobile/Myapp2

If i change the root path in "web server profile config" to "C:\inetpub\wwwroot\PBmobile" it deploys fine to correct folder
but the app does not work, it still thinks "http://myserver.com/Myapp1" is the correct address

If i try to change "Web Folder" in application profile to "PBMobile/Myapp1" i get an error saying illegal characters

When deploying to "http://myserver.com/Myapp1" everything works fine

So how do i solve this ?
This is required for the internet connected secure server that will forward only calls with /PBMobile/ to our test server

 

Accepted Answer
Jonas Blomgren Accepted Answer Pending Moderation
0
Votes
Undo

Posted this as a bug and finally got an answer

"We don't have a feasible workaround for this, you can deploy application to web root path only, but not sub folder."
 

 

Comment
There are no comments made yet.
  1. Friday, 22 September 2017
  2. PowerServer Mobile
  3. # Permalink
Jonas Blomgren Accepted Answer Pending Moderation
0
Votes
Undo

Can you or can you not deploy the PB mobile app to "root/common/appfolder" instead of the default "root/appfolder"  ?

I really need some answers to be able to evaluate this product.

Thanks

 

Comment
Hi Jonas,



 



Have you already tried setting that up in the “PowerServer Toolkit Configuration Wizard” (Configuration Basic Settings > Web folder)?  And then setting up the proper configurations in “Appeon Application Package Wizard” (Configure App Settings > General)? If not, please try it and also let us know how this went for you. 



 



I'm also adding this link to an awesome Appeon tutorial, created by Chris, explaining the steps of how to do this. Hope this helps.



 



Regards,



Govinda Lopez 

  1. Govinda Lopez
  2. Wednesday, 13 September 2017




Can't enter "/" in "web folder" (illegal charcter) , so how do i do this ?



 



 

  1. Jonas Blomgren
  2. Tuesday, 19 September 2017
There are no comments made yet.
  1. Monday, 11 September 2017
  2. PowerServer Mobile
  3. # 1
Jonas Blomgren Accepted Answer Pending Moderation
0
Votes
Undo

Hello Again

Yes i have full control for IIS_IUSRS on all folders and subfolders

I must miss something when trying to explain my problem, sorry about that ;)

How do i configure PowerBuilder/PowerServer so that the mobile app is installed and runned from http://myserver.com/commonfolder/myapplication ?

Where in in powerbuilder powerserver tool kit can i tell that my app should be deployed to and runned from "commonfolder/myapplication"

or if it is a setting in the AEM console

or if it's a setting in IIS

or if i must do something when installing PowerServer.

Thanks again.

Comment
There are no comments made yet.
  1. Thursday, 7 September 2017
  2. PowerServer Mobile
  3. # 2
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Jonas;

    My sincere apologies ... read your issue backwards. After re-reading, I see that your issue is the deployment under wwwroot. That should not be an issue if the IIS master user is registered against the IIS folder and has full permissions. As you can see below, here is my working wwwroot folder property settings with IIS_IUSRS having full permission on the folder ...

 

Note: Also make sure that IIS_IUSRS also has the same privileges for wwwroot's all sub-folders as well (Advanced settings).

HTH

Regards ... Chris

 

Comment
There are no comments made yet.
  1. Wednesday, 6 September 2017
  2. PowerServer Mobile
  3. # 3
Jonas Blomgren Accepted Answer Pending Moderation
0
Votes
Undo

Hi Chris

Thanks, i have same permissons on the folder "WWWROOT/PBMobile"

But where do i change ?, is the "web server profile config" the right place or somewhere else ?

when deploying without errors and press "run" the QR link thing still says "http:/myserver/myapp1"  with changed "web server profile config" pointing to WWWROOT/PBMobile

(i'm a rookie on this)

Comment
There are no comments made yet.
  1. Wednesday, 6 September 2017
  2. PowerServer Mobile
  3. # 4
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Jonas;

  FWIW:  The reason your Apps work properly under WWWROOT is probably related to its folder permissions and the registration of the IIS_USR account on that folder. Your Apps outside WWWROOT need to have the same persmissions as WWWROOT. Once I do that on my systems, my Apps all work OK outside wwwroot.

HTH

Regards ... Chris

Comment
.delete

  1. Jonas Blomgren
  2. Wednesday, 6 September 2017
There are no comments made yet.
  1. Wednesday, 6 September 2017
  2. PowerServer Mobile
  3. # 5
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.
We use cookies which are necessary for the proper functioning of our websites. We also use cookies to analyze our traffic, improve your experience and provide social media features. If you continue to use this site, you consent to our use of cookies. Learn More