1. Yun JongPhil
  2. PowerServer 2020 or older (Obsolete)
  3. Friday, 18 May 2018 04:23 AM UTC

In DW window, Oracle Porcedure delivers a query of the results.
Tibero Procedure on the same DW window will generate an error when querying results.


I ask if there is any solution.



( as_site_code char,
    as_ym char



        select trim(trade_code) trade_code, work_code , item_code , work_seq_no, seq_no , trim(t_desc) t_desc, size_desc , trim(unit) unit,
            gencont_qty ,estimate_qty , gencont_unit_price, gencont_amt,
            estimate_unit_price, estimate_amt, genpay_lqty,last_used_qty,
            gencont_last_used_amt, estimate_last_used_amt, genpay_cqty, cur_used_qty,
            gencont_cur_used_amt, estimate_cur_used_amt,
            genpay_tqty, total_used_qty, gencont_total_used_amt, estimate_total_used_amt
        from temp_pa_ret

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 18 May 2018 15:11 PM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 1

Hi Yun;

  Unfortunately, the Tibero DBMS is not officially supported by Appeon products at this time.

Thus you would be one your own using this DBMS.

Regards ... Chris

There are no comments made yet.
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Monday, 21 May 2018 07:23 AM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 2

Hi Yun,


I'm using Tibero with Powerbuilder too. I'll have a look when I have some time today if I can reproduce the problem you're having.

We use JDBC.. ODBC and OLEDB do some things right but lots of them wrong.


There are no comments made yet.
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Monday, 21 May 2018 09:48 AM UTC
  2. PowerServer 2020 or older (Obsolete)
  3. # 3


I've created this stored procedure on our Tibero database, to try reproduce your problem:

create or replace procedure test_miguel
(as_parm1 char,
as_parm2 char,
cur out sys_refcursor)
  OPEN cur for select dummy from dual;


I then created a datawindow (connected through ODBC profile with default options) and did a retrieve:

It works without any errors !

Which version of Tibero are you using on what operating system? (if you do a "tbboot -version" you will get the information)

C:\Windows\system32>tbboot -version

Tibero 6   (DB 6.0 FS06_CS_1703)
CYGWIN_NT-5.2-WOW64 tbvwin-2003-64 1.7.13(0.260/5/3) 2012-04-05 12:43 i686 Cygwin version (little-endian)

Patch files (FS06_CS_130562b)
Compiled at Feb  5 2018 04:22:49

Which driver do you use to connect (odbc, oledb, jdbc)?



  1. Yun JongPhil
  2. Tuesday, 22 May 2018 23:30 PM UTC
Thank you for your hard work.

Problems occur when you are in a web(Appeon) environment, not in a c/s environment.

Is it possible even with the Appeon+ jdbc  + Tibero(db) environment?

  1. Helpful
  1. Yun JongPhil
  2. Tuesday, 22 May 2018 23:30 PM UTC

  1. Helpful
  1. Miguel Leeuwe
  2. Wednesday, 23 May 2018 06:39 AM UTC

I haven't tried it with web environment. A few months ago, I tried to use Appeon WEB to run our application in a web browser, but ran into many problems, since Appeon WEB does not support "Other ODBC" being Tibero ODBC. I've been told that JDBC could work, but then you cannot use IIS and have to setup up for Java environment. Maybe by using JBOSS. Since at my job we use a lot of C#, setting it up with JBOSS wasn't worth the trouble. 

Did you manage to setup Appeon Powerserver WEB with Tibero? I didn't succeed, please let me know how you did that :)

In a few weeks, I'll try to make Appeon WEB work with Oracle, which is a big job, since we use a newer version of PFC's which are not supported by Appeon WEB at all. I have done a lot of modifications already but ran out of time.

When I go back on that project, I will try to run your stored procedure and see if it also fails with Oracle ODBC. If so, Appeon will have to fix it, since they do support Oracle ODBC. Sorry that I cannot help you more right now.

kind regards,

Miguel Leeuwe

​NOTE: In our client-server environment, we use JDBC only (except for ODBC that we use for Crystal Reports) and it works great.

  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.