1. Jon Stoller
  2. PowerBuilder
  3. Saturday, 08 December 2018

I defined a dropdown list in the datawindow painter. 

I accidently added a few lines at the bottom of the list.  I don't want them, but I can't figure out how to delete or remove them. 

DETAILS/EXPLANATION:  I was entering the lines in the dropdown list where you enter the display value and the data value.  I accidently tabbed through the lines at the bottom of the list a couple of extra times and saved.  The last couple of dropdown lines with no display or data values were saved.  If you look at the window at runtime the absolute last line is not displayed but the other lines above it are displayed as blank. 

I don't see a way to remove the blank lines, or for that matter, any lines.  I can blank them out but I cannot get rid of them completely.  How can I do it?  Is there a way?  

Jon Stoller

jon@akaware.com

973-9720-8211

 

Kevin Ridley Accepted Answer Pending Moderation
0
Votes
Undo

That sounded odd to me so I just tried it.  Looks like you can select the number of the next to last one and hit the delete key and it will remove that entry.  So if you have 10 good entries and you added 2 blank ones, just select 11, hit delete and the 11th entry will be gone.  If you still have a blank one at the end, do the same for the 10th item and just retype it into the last box.  Obviously Edit Source will work too as Roland said.

Comment
There are no comments made yet.
  1. Monday, 10 December 2018
  2. PowerBuilder
  3. # 1
Roland Smith Accepted Answer Pending Moderation
1
Votes
Undo

I would use Edit Source on the DataWindow and delete it from the source.

In this example, there is a tab character between the Display Value and the Data Value which is followed by forward slash.

 

values="one 1/two 2/three 3/"

 

Comment
Yes, that's the only way to remove blank or unwanted rows from the dropdownlist box.
  1. Sivaprakash BKR
  2. Monday, 10 December 2018
Its the same for a standard "Edit Mask" control as well. Please open a Support Ticket for this issue in order to get a proper IDE fix. If I recall correctly, I seem to remember that this problem was also logged against PB way back in the old Sybase days - but never fixed.
  1. Chris Pollach
  2. Monday, 10 December 2018
There are no comments made yet.
  1. Saturday, 8 December 2018
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.