1. Tracy Lamb
  2. PowerBuilder
  3. Tuesday, 31 July 2018 17:23 PM

I'm using PFC (migrated multiple times over the years) and recently had to add master/detail linkage service to an existing window.  I use linkage service in many other windows with no problem, but this one just won't work for some reason.  I'd like to watch variables as the program is running in debug mode, but don't know how to do that.  I can set a breakpoint - that works fine.  But then what?

I'm not finding anything in the online manuals about debugging.  Any suggestions are greatly appreciated.

~~~Tracy

 

Accepted Answer
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 31 July 2018 17:34 PM
  2. PowerBuilder
  3. # Permalink
1
Votes
Undo

Hi Tracy;

   Once you have some breakpoints set .. just run your App via either "debug" icon on the PB IDE's toolbar ...

TIP: In the PB Help file, search for the keyword "Debugger".  wink

HTH

Regards ... Chris

Comment
Thank you! I never thought to check the PB Help Contents....

I was able to see all of the variables at the break points and set variables to watch. Discovered that my linkage commands for some reason weren't firing after the initial of_SetLinkage(TRUE) statement. I moved the remaining statements from the dw's constructor event to the window's open event and Voila, works as advertised!
  1. Tracy Lamb
  2. Tuesday, 31 July 2018 21:25 PM
Excellent news Tracy! :-)
  1. Chris Pollach @Appeon
  2. Tuesday, 31 July 2018 23:52 PM
I suspect that is because the constructor on the dw probably firing BEFORE wherever you had the linkage code.
  1. Kevin Ridley
  2. Wednesday, 1 August 2018 14:40 PM
There are no comments made yet.


There are replies in this question but you are not allowed to view the replies from this question.