1. Oscar Naranjo
  2. PowerServer Web
  3. Monday, 03 December 2018

Hi everyone,

We are migrating a PowerBuilder application to the web with PowerBuilder 2017 universal version, our database connection has always been using a username master so we always put the real user's name as a connection parameter of the database (Ex. DbParm="Host='Oscar. Naranjo' ") to have more information of the connection, but now in web environment it does not work. Does someone has a suggestion for us?.

BTW: our database is ASE Sybase 15 and we are using the native driver ("ASE Native Driver") in AEM.

Best Regards,

Oscar Naranjo 

 

Oscar Naranjo Accepted Answer Pending Moderation
0
Votes
Undo

Hi Chris,

Thank you for your fast response, we are working with "Dynamic Database Connection = ON" ever. Also, we are working with "CacheName" parameter to connect with different databases using DbParm, however, any other parameters don't work from DbParm. For example, we are using "Extended Options" in the Data Source instead of DbParm for CharSet parameter.

Best Regards,

Oscar Naranjo 

 

 

Comment
The CacheName feature is great but, limited in its DBParm options support. This may well be a PowerServer enhancement request. You can open a Support Ticket for the "Host=???" feature and mark it as an enhancement. I also think that the "AppName=???" should be supported as well IMHO. I have used both of these DBParm settings many, many times with SS & ASE in native PB applications.

  1. Chris Pollach
  2. Monday, 3 December 2018
There are no comments made yet.
  1. Monday, 3 December 2018
  2. PowerServer Web
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Oscar;

  Suggestion: Try turning ON "Dynamic Database Connection" in the DataSource connection definition in your PowerServer (AEM => Server=> Resources => DataSource =>  

HTH

Regards ... Chris

Comment
There are no comments made yet.
  1. Monday, 3 December 2018
  2. PowerServer Web
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.