1. Marcus Leung
  2. PowerBuilder
  3. Monday, 4 May 2020 04:32 AM

Which highest version of MS SQL Server is officially supported by PB 2019 / PB 2019 R2?

 

Anyone use PB 2019 with SQL 2019 ? (which driver do you use ~ OLE DB / Native driver ?)

 

Thanks

 

Accepted Answer
Michael Kramer Accepted Answer Pending Moderation
  1. Monday, 4 May 2020 07:24 AM
  2. PowerBuilder
  3. # Permalink
1
Votes
Undo

I'm running PB 2019 R2 towards MSSQL 2019 using ADO.NET, OLEDB, and SNC.

I personally prefer SNC for MSSQL just as I prefer ORA for Oracle. In F1-Help for SNC driver you can see what the supported versions of MSSL are. SNC in PB 2019

For environments where PB apps coexist with .NET components I often switch to ADO.NET to bring less complexity to the OPS people's busy workday.

I believe MSSQL was added in maintenance release of PB 2019 several months back - if it wasn't in the product from launch. Your F1-Help will tell you which version is officially supported in your installation.

HTH /Michael

Comment
There are no comments made yet.


There are replies in this question but you are not allowed to view the replies from this question.