1. Hans Groeneveld
  2. PowerBuilder
  3. Tuesday, 21 June 2022 11:55 AM UTC

Our Admin installed new Git and Windows updates.

After that we could not Pull or Push from Powerbuilder. We got this message:

 ---------- Source Control: Errors   (13:39:20)
Git detail error info: Unknown certificate check failure
Git client error code: Server certificate is invalid.
Failed to push workspace.
 ---------- Finished Errors   (13:39:20)


As workaround we use Git from the Windows Explorer, to Pull and Push, and do a Refresh in PowerBuilder. That works ok.

All other development tools (ex Visual Studio) work fine with Git.

Using PB 2019 R3.


1. Can this error be solved, maybe by some Git setting?

2. If 1 is a No. Can this be solved in PB 2022? Because, I found modifications about Git in the release documentations.


In the other projects (non-PB) we use SSH instead of HTTPS. But SSH is not accepted within PowerBuilder.







Hans Groeneveld Accepted Answer Pending Moderation
  1. Friday, 24 June 2022 12:14 PM UTC
  2. PowerBuilder
  3. # 1

It seems like a certificate problem on the Powerbuilder end.

How uses Powerbuilder Root and Intermediate certificates, from the Windows Certificate manager ?


Does Powerbuilder comes with his own Git implementation or does Powerbuilder use a Git-scm installation on the Windows machine ?

We have tested some Git settings without any effect on Powerbuilder

Will PB2022 handle Git implementation in a different way?


Wat we know:

            No proxy server

            Credentials for our Gitlab server are correct

            Certificate is correct, the normal git (from the commandline over https) works with newer Root and Intermediate certifcates.

            To make Git (commandline, https) work, we have to add the root and intermediate certificates to Git.

             Password does not contain weird characters, is not changed since half a year.



  1. Tom Jiang @Appeon
  2. Tuesday, 28 June 2022 02:16 AM UTC
It seems like that you are using an invalid or self-signed certificate for your git repository. Currently, we suggest that you use a CA certificate for your server to resolve the issue or you may work around it by using another Git tool.


PB IDE use a built-in Git tool for Git operations. It doesn't use the Git-scm on your machine. In the meantime, we will consider supporting the http.sslVerify Git setting in a future release that will enable you to use a self-signed certificate.
  1. Helpful
  1. Hans Groeneveld
  2. Tuesday, 28 June 2022 06:19 AM UTC
We do not use a self signed certificate…

But an official Sectigo SSL certificate.

  1. Helpful
  1. Tom Jiang @Appeon
  2. Wednesday, 29 June 2022 03:42 AM UTC
If that's the case, please report a bug via our support ticketing system at https://www.appeon.com/standardsupport/newbug and include as much information as possible about the situation of your application, as well as all the technical specifications of your environment. Please add all relevant error messages, error logs, screenshots, and a replicable test case.
  1. Helpful
There are no comments made yet.
Hans Groeneveld Accepted Answer Pending Moderation
  1. Thursday, 23 June 2022 07:17 AM UTC
  2. PowerBuilder
  3. # 2

Thanks Tom.

When I change settings in the properties of the Workspace I got a logon error.

Source Control
Cannot connect to the repository. Please make sure you have specified the correct user ID, and password.

But the logon information is correct.

We have found a workaround by doing the Pull and Push with another Git tool, outside of PB.

I hope PB 2022 will solve this problem with certiificates.


  1. Tom Jiang @Appeon
  2. Friday, 24 June 2022 02:37 AM UTC
Hi Hans,

The installation of Git may affect the proxy settings and saved credentials, which in turn may give you the certificate error and login error.

Please review the following checklist and see if it helps resolve the issue. If the problem still happen, Please open a ticket through our support portal at https://www.appeon.com/standardsupport/newbug so we can track and further analyze the issue.

#1 Do you use a proxy for connecting to your repository?

If using the proxy server, configure the proxy server IP address and port number in the PB.ini file (by default, the INI file is located in C:\Users\<username>\appdata\local\appeon\powerbuilder 19.0\ in Windows 7 or later). Copy the following section to the INI file and set the appropriate value for the proxy server:







#2 Is it possible that your credential is expired?

Try delete the account credential stored on Windows:

1. Open Control Panel.

2. Click on User Accounts.

3. Click on Credential Manager.

4. Click the Windows Credentials tab (or Web Credentials).

5. Select the account.

6. Click the Remove button.

Then try to connect to workspace from PowerBuilder IDE again.

#3 Password character

If you are using username and password authentication, please check if your password contains any character that is not on a standard US keyboard. We had a case where it failed to connect to the server when there is the character "§" in the password. I suggest that you test with an account that doesn't use any special characters in the password.

#4 Git settings in other tools

One user resolved a similar issue by going to MS Visual Studio Team Explorer Git > Setting, change Credential Helper from 'GCM for Windows' to 'Unset'

#5 Generate a new password

One user resolved a similar issue with BitBucket after regenerate a new password at https://bitbucket.org/account/settings/app-passwords/

#6 Delete the following keys in registry (please backup them just in case) and connect with PB IDE again and see if it resolves the issue

* Computer\HKEY_CURRENT_USER\SOFTWARE\Sybase\PowerBuilder\21.0\Workspace\[Your workspace path]\SourceControlVersion2

* Computer\HKEY_CURRENT_USER\SOFTWARE\Sybase\PowerBuilder.\Workspace\Git


Tom Jiang

  1. Helpful
There are no comments made yet.
Tom Jiang @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 22 June 2022 09:17 AM UTC
  2. PowerBuilder
  3. # 3

Hi Hans,

Please add the following to your PB.ini file (by default, the INI file is located in C:\Users\<username>\appdata\local\appeon\powerbuilder 19.0\ in Windows 7 or later).
Enable log in Workspace properties > Source Control tab, and then try to reproduce the issue again and see if it gives any extra error information.


Tom Jiang


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.