1. Aimee Stephens
  2. PowerBuilder
  3. Friday, 15 October 2021 21:36 PM UTC

This is only happening to one of our developers.  When she goes into PB 2019 R3 she can click on the workspace and see all of the Git options.  However, when she drives down into any of the pbls there are no green dots next to any of the objects and when she right clicks on them there are no Git options available.  We have a standard setup procedure that is used to clone the repository (stored in Bitbucket) and all other developers have no issues.  In windows explorer there are green checkmarks next to the we_objects folder and the .gitignore file.  We don't store the pbls in the repository due to space restrictions so the folders containing the pbls are manually copied from the "source directory".  This was working for her a few months ago when we were doing our testing.  Once final testing was finished we created a new repository and had all developers delete their old directory and perform the steps to clone the new repository.  Since then just this one developer is experiencing the issues described above.  We've gone through the steps numerous times, uninstalled/re-installed Git and Tortoise Git, rebooted her system and nothing has worked.  Has anyone else experience anything like this?  We're new to PB 2019 (just migrated from PB7) and new to using Git so any advice/help would be very appreciative.



Miguel Leeuwe Accepted Answer Pending Moderation
  1. Saturday, 16 October 2021 21:17 PM UTC
  2. PowerBuilder
  3. # 1

I haven't used Git with powerbuilder. Have you tried doing a full 'refresh' of all the objects in the target? Try doing a GetLatest, marking all the objects.

Maybe someone else can give better advice on this.


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.