1. David Haas
  2. PowerBuilder
  3. Wednesday, 20 June 2018

I'm converting apps to PB 2017.  When trying to SaveAs PDF, it works in PB 11.5 but not in PB 2017 app (these apps are deployed to RDS and ran as remote app).  Are there any PB runtime DLLs that are required for this that I might be missing?  Do I need to re-create the Sybase DataWindow PS printer?  I have this installed on servers but did that using the 'ADIST5.INF' for PB11.5 when setting up printer a while back.  Not sure if I need to recreate using this file in PB 2017 Shared folder.

 

Thanks for any help!!

Dave

Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi David;

   FYI: You have a minimum of two choices for PDF generation in PB 2017 ... GhostScript (GS) or the new NativePDF feature.

      If you are using GS - then the set-up will be the same as in PB 11.x., you will need to a) download and install GS b) create & then set-up the "Sybase DataWindow PS" (or equivalent PostScript) printer definition on the target PC. You also have to make sure that you use the correct bitness of GS that matches the O/S you are deploying to. Also, I would highly recommend that you use the latest version of GS - as it has Font improvements and a new .INF that is better to use for the "Sybase DataWindow PS" printer install.

    If you use the new PB2017 Native PDF feature, you do not have to install anything on the deployment machine. Just make sure that you deploy the new PBPDF170.dll as PDF handling is encapsulated within that library. This will be automatic if you use the PB Packager utility that comes with PB2017.

HTH

Regards ... Chris

 

 

Comment
Thanks Chris!!  Just before you replied,  I think I found the problem.



I remembered at one time, I was starting to migrate apps from 11.5 to 12.6...never finished as I got busy.  Basically it had to do with 2 files in the 'C:\Program Files\gs\gs9.10\bin' folder...gswin32c.exe & gswin64c.exe.



When I called support they said that 12.6 required 64 bit code but this environment had hardcoded looking for gswin32c.exe name.  So they told me to change the '64' in the filename of the 64 bit version to '32' and it worked.  So in doing this, there was no longer a gswin64c.exe file...which is why appears now why I couldn't saveas PDF in 2017.  I went and found the original gswin64c.exe file and copied it to the BIN folder and Walla,  it works now!!!



Guessing call to this GS exe in 2017 is not hard coded as the support person stated earlier.



As time permits,  I may test the Native PDF to see how that works/looks

  1. David Haas
  2. Wednesday, 20 June 2018
Hi David;



  Great news!  



  FWIW: No PB version ever hard coded the GS EXE name in the PB GS implementation for PDF support.



Regards ... Chris

  1. Chris Pollach
  2. Wednesday, 20 June 2018
Not hard-coded, it is based on the GS registry settings.

  1. Kim Berghall
  2. Thursday, 21 June 2018
There are no comments made yet.
  1. Wednesday, 20 June 2018
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.