1. Fernando Leal
  2. PowerBuilder
  3. Monday, 26 October 2020 20:11 PM UTC

Hi everyone,

I am having trouble executing the timer function.
The system does nothing when I run the .EXE \ PBD on Windows 7 and 10 workstations.
In my workstation that is Windows 10 it works in interpreted mode and from the .exe.

I have tried to run Timer (2) from a window with no code and it doesn't work.
From various events and it doesn't work.
Am I missing a DLL or program?


thank you very much for your help,


Andreas Mykonios Accepted Answer Pending Moderation
  1. Tuesday, 27 October 2020 05:54 AM UTC
  2. PowerBuilder
  3. # 1

Hi .

What is the code you put in timer event of those windows? Have you tried to run your application in debug mode? Does it enters to the timer event?


  1. Fernando Leal
  2. Tuesday, 27 October 2020 17:32 PM UTC
Hi Andrea's, I have tried to run the timer in dubug mode, from the .exe and the timer does not run.

The system does not enter the Timer () event, I do not know why it does not do so on different workstations and on my computer.

Event Timer ()

li_timer = li_timer + 1

messagebox("Timer", "Ingrese: " +String (li_timer))

thanks and regards,


  1. Helpful
There are no comments made yet.
John Fauss Accepted Answer Pending Moderation
  1. Tuesday, 27 October 2020 01:44 AM UTC
  2. PowerBuilder
  3. # 2

Hi, Fernando - 

Have you tried, just as an experiment, using the PB Timer object instead of the Timer PowerScript function?

Regards, John

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.