1. Ludwin Feiten
  2. PowerBuilder
  3. Monday, 9 August 2021 15:52 PM UTC

Hi experts,

We notice strange crashes of PB apps  with PB19 R3 (2670) during runtime. We have a strongly suspect that this are memory problems.

I wanted to use PB_HEAP_DEBUG and PB_HEAP_LOGFILENAME to inspect the memory usage.

But it looks like this feature will not work: The file is created but there is no output written into it.

Do I have to set an additional parameter or s. th. else? (The documentation is pretty poor).

Or doesn't it work anymore?

How can share his/her experience?

TIA, Ludwin

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 11 August 2021 19:20 PM UTC
  2. PowerBuilder
  3. # 1

Hi Ludwin;

   My STD Framework uses the "PB_HEAP_DEBUG" feature. I'll double check this with my PB2019 R3 & PB 2021 framework versions this evening & report back here.

Regards ... Chris


There are no comments made yet.
Ludwin Feiten Accepted Answer Pending Moderation
  1. Wednesday, 11 August 2021 10:48 AM UTC
  2. PowerBuilder
  3. # 2

Thanks for the suggestions.

But that does not answer my question.

And - if YES -  how do I use it?

Thanks again, Ludwin

  1. Chris Pollach
  2. Friday, 13 August 2021 01:46 AM UTC
Hi Ludwin;

I have now confirmed that the PB Heap Dump feature that has been working before in the STD Framework with lower versions of PB, is now broken in both the PB2019R3 and PB2021 releases. I have opened ticket # 7096 with Engineering. It could be that this feature was removed or just commented out by mistake as it was associated with EAServer. However, that feature was the "SybHEAP_Dump()" API. The PBHEAP_Dump() function does not GPF but it now no longer produces any trace/dump file either. Let's see what engineering says.

Regards ... Chris
  1. Helpful
  1. Ludwin Feiten
  2. Friday, 13 August 2021 07:28 AM UTC
Hi Chris,

Thank you very much for testing and opening the ticket.

I hope they can fix it soon.

Best regards, Ludwin
  1. Helpful
There are no comments made yet.
Mickey Hillel Accepted Answer Pending Moderation
  1. Tuesday, 10 August 2021 06:49 AM UTC
  2. PowerBuilder
  3. # 3

Have you tried checking on the Event Viewer in Windows.

Especially Windows Logs > Application filter for Errors only.

Might find something interesting there...

There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Monday, 9 August 2021 21:07 PM UTC
  2. PowerBuilder
  3. # 4

Have you tried the 4GB_PATCH.EXE?

Make a copy of the EXE to be patched
Double-click the path
Select the EXEW to be patched
Click OK
Test the patched exe

Good Luck,


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.
We use cookies which are necessary for the proper functioning of our websites. We also use cookies to analyze our traffic, improve your experience and provide social media features. If you continue to use this site, you consent to our use of cookies.