1. shoaib siddiqui
  2. PowerServer Mobile
  3. Friday, 11 January 2019

Getting Error 12031 and some time Error 12002 while deploying.  Powerserver is installed on windows 2016 and license has been activated successfully. 

PowerServer connection was also successful during configuration. I searched appeon help, could not find error code documentation.

 

 

Who is viewing this page
shoaib siddiqui Accepted Answer Pending Moderation
0
Votes
Undo

Thanks Chris,

we work here under very strict and secured environment as you know , we spoke in past.

FYI: on developers machine no local server  (IIS) is allowed, or no FTP allowed on Windows server 2016.

so for that reason, I cannot complete the Configuration Wizard since it requires PowerServer AND Web
server definition. Hence there is no application profile to select from...

I did create the exe, went fine, but I cant create the profile,  whats the next step to convert or Package. I tried Package wizard it shows blank:

 

 

 

Comment
Yes .... you must deploy to a *local* PowerSever 1st. Then you can package your App for the remote PS.
  1. Chris Pollach
  2. 5 days ago
There are no comments made yet.
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Shoaib;

  To deploy manually, use the PS "Package" tool on the PS Toolkit's toolbar within the PB IDE. That will create an MSI file for you to run on the remote PowerServer that will install your PS Web/Mobile App on that instance.

HTH

Regards ... Chris

Comment
There are no comments made yet.
shoaib siddiqui Accepted Answer Pending Moderation
0
Votes
Undo

Yes, our server does not offer FTP at all, how can I package it and install manually on Server?

Comment
There are no comments made yet.
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Shoaib;

  In order to deploy directly to a remote PowerServer instance, the IIS on that machine must have FTP services enabled & configured. Could this be your problem?

FYI: https://www.appeon.com/support/documents/appeon_online_help/2017/powerserver_toolkit_user_guide/ch03s02s03.html#twoRequirements

Regards ... Chris

Comment
Thanks Chris,

I was able to go further by Disabling SSL on IIS temporarily , and install via MSI (installer file).

but I cannot connect the mobile device, meaning trying to get to application through QR code or manually entering the the https address in Appeon Workspace

the error reads: could not resolve host name.

Is there any documentation/help to setup firewall rules multiple mobile device to communicate with PowerServer for both Web app or Mobile app.?



  1. shoaib siddiqui
  2. 3 hours ago
Hi Shoaib;



Since PowerServer is just an application (assistant actually) running under IIS. The configuration for firewalls, proxy servers, Anti-Virus, Active Directory, etc settings would be covered in the IIS documentation. The key is that any mobile device would be able to see the IIS instance (probably by its IP address vs DNS) publicly.



A big issue could be if your IIS instance (where PS is installed) is behind a corporate firewall where its not exposed to the outside world. In this case, you may need to create a public IIS instance and then create a "trust" (aka White Hole) through the firewall between the two IIS instances. Once that is set-up, you can then use URL redirection in the public IIS to get connected to your internal IIS behind the corporate firewall. This will now allow you to get to PowerServer from outside your organization (or even a cloud provider).



The best would be to speak with your network support team at your organization to get this set-up. Once this is done, an easy sanity check would be to open the mobile device's web browser and then type "http:///AEM". If the AEM App appears, your communicating OK through IIS to PS. Now you should be able to launch your Mobile App.



Regards ... Chris
  1. Chris Pollach
  2. 1 hour ago
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.