1. Justin Perticone
  2. PowerBuilder
  3. Sunday, 13 December 2020 23:20 PM UTC

Hi all,

I have a program that must be able to retrieve data based on the previous day's "Approved Date."  I am using PowerBuilder 2017 and I am accessing a DB2 database.  The only retrieval argument in my query is of DateTime type (see query attached below along with the column property the retrieval argument is compared to). 

The query checks that timestamp_acptd > :ra_date.  I have tried many combinations of formats and retrieval argument variable types (Date, DateTime, String).  Every combination I have tried results in a SQLSTATE 42601 Illegal Symbol error (screenshot attached).

I can simply hard code a DateTime (TimeStamp) in this format in place of the retrieval argument to get the results I would like for a day: '2020-12-08 00.00.00.000000'.  The timestamp_acptd field is of type TimeStamp in the DB2 database. 

The application cannot run in our desired way without me being able to successfully pass a DateTime value in the DataWindow retrieval.  What am I missing or doing wrong?  We are trying to complete this program quickly and on short notice so any and all help is appreciated!

Thanks,

Justin

Attachments (3)
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 14 December 2020 00:22 AM UTC
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi Justin;

  This DB2 error code on the IBM website indicates that column names with spaces are not supported.

Regards... Chris

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.