1. Troy Cowan
  2. PowerBuilder
  3. Friday, 17 May 2024 18:00 PM UTC

We're experiencing an issue with a legacy powerbuilder application and could use some advice on how to proceed. 

We recently switched build servers where this application is built, and the application behaves differently based on which build server is used. 

When built on the old build server, the application works as expected. 

When built on the new build server, the application throws an error. 

We have troubleshot the problem down to one datawindow that, when the Retrieve method is run on in it, returns a -1. We added code to capture the sqlerrtext and sqldbcode right after the Retrieve, and they are an empty string and 0. We also used a packet sniffer to determine that no Select statement is sent over to the database during this Retrieve. 

So we have a datawindow that fails with a -1 without attempting to run a Select statement. This Datawindow and its embedded Select statement has worked as is in the past, and in fact continues to do so when we build the application on the old build server. 

So, two questions:

Is there any techniques for trying to determine why the Datawindow is returning a -1?

What should we look for for differences between the two build servers? They both are using

    PowerGen® Version 12.5.03 for PowerBuilder® V 2021
    PowerBuilder ORCA Version:

John Raghanti Accepted Answer Pending Moderation
  1. Friday, 17 May 2024 19:48 PM UTC
  2. PowerBuilder
  3. # 1

Differences in the PB deployment? Have you tried comparing the pb.ini or config files (e.g. pb220.exe.config)?

There are no comments made yet.
mike S Accepted Answer Pending Moderation
  1. Friday, 17 May 2024 18:37 PM UTC
  2. PowerBuilder
  3. # 2

sounds like the datawindow is missing. if you build to single exe then the datawindow must listed in the pbr.

  1. Troy Cowan
  2. Monday, 20 May 2024 13:23 PM UTC
Thanks. I checked, and the datawindow is listed in the pbr.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.