1. Moshe Tangi
  2. PowerBuilder
  3. Friday, 12 October 2018

Hello all ,

 

I have a client / server database application .

Sometimes when I am running reports ( dw ) , after about a minute I get an error message says something like:

 can not complete operation due the time elapsed …. 

and sometimes its works great . I can't determine any rule .

Running the same sql under Mssql studio management works great .

I am using  Ado.Net for connecting .

Application is pb 2017 R3 .

OS : window server 2012 R2.

DB : Mssql 2014

The db file is about 2 GB and the log is 13 GB.

I have checked indexes and rebuild all again and again .

 

remark : Running the same reports with Sybase sqlanywhere 11 , I have never saw a message like that ( with smaller db files , but still  never something like that )

 

Any ideas ? Are there any parm I should include in the connection string ?

Thanks

Accepted Answer
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Moshe;

   Have you tried using an SNC connection to SS instead of ADO.net (middleware)?

Sounds like you are exceeding a SS "timeout" setting. Have you checked the SS logs?

Regards ... Chris

Comment
There are no comments made yet.
  1. Friday, 12 October 2018
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

Hi Moshe

The error you describe sounds like a timeout processing the query operation. This is most likely caused by something at the database or other connections blocking your query. It could be somethin gin the ADO and Chris's suggestion should be tried too.

You may want to look at this:

https://blog.sqlauthority.com/2016/01/26/sql-server-timeout-expired-the-timeout-period-elapsed-prior-to-completion-of-the-operation-or-the-server-is-not-responding/

I hope this helps, but we do have very little to go on.

Regards

David

Comment
There are no comments made yet.
  1. Friday, 12 October 2018
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.