1. Irina Tokar
  2. PowerBuilder
  3. Monday, 11 December 2017 16:37 PM

I have a trial version of PB2017 on my machine. I successfully migrated the some application from the PB12.6 and try to build exe file from command line. But failed with error: Application 'main' not found in library.

My command line :

"c:\Program Files (x86)\Appeon\Shared\PowerBuilder\pbc170.exe" /d "D:\PBD Deployment\Main\main.pbt" /o "D:\PBD Deployment\Main\main.exe" /w y /m n /x 32  /v "0111" /fv "111" 

What i do incorrect?

in other side we have a build machine with official version of PB2017 and on the build machine the command line works.

Command line on the build machine:

"c:\Program Files (x86)\Appeon\Shared\PowerBuilder\pbc170.exe" /d "D:\PBD Deployment\Main\main.pbt" /o "D:\PBD Deployment\Main\main.exe" /w y /m n /x 32  /v "0111" /fv "111" /out C:\mainLog.log 

If i run this command line in my machine, i got error :Unsupported value /out for the 15th parameter

Can it be because the trial version? or i missing something? 

Ken Guo @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 30 May 2018 09:48 AM
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi Irina Tokar,

Could you let me know if this issue is fixed. If you still have the issue, can you provide us a sample case to reproduce the issue?

 

Hi Koen de Vos,

I saw the ticket you reported in the system. We also need you to provide a sample case that can duplicate the issue. We can’t move forward if we don’t have a case that can duplicate the issue.

 

Best Regards,

Ken

Comment
There are no comments made yet.
Koen de Vos Accepted Answer Pending Moderation
  1. Tuesday, 15 May 2018 10:04 AM
  2. PowerBuilder
  3. # 2
0
Votes
Undo

I get the same error: "Application 'flexkids' not found in library"
Did you found a solution for this problem?

The command line:
& "C:\Program Files (x86)\Appeon\AutoCompile 17.0\pbc170" /d "C:\tools\jenkins\workspace\Builds\Flexkids\flexkids\flexkids\FlexKIDS.pbt" /o "C:\tools\jenkins\workspace\Builds\Flexkids\FlexKIDS\flexkids\FlexKIDS.exe" /r "C:\tools\jenkins\workspace\Builds\Flexkids\FlexKIDS\flexkids\FlexKIDS.pbr" /w n /f /m n /x 32 /bg y /p "FlexKIDS" /cp "Dicon Development Center" /de "FlexKIDS" /cr "Dicon Development Center" /v "3.0.9.1" /fv "3.0.9.1" /ge 2 /le 0 /ps n  > Deploy.log

It is the same as the example in de project painter.
The full build completed successfully.

Comment
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 11 December 2017 19:32 PM
  2. PowerBuilder
  3. # 3
0
Votes
Undo

Hi Irena;

   Did you create the PBC command line by copying all the required values from your App's deployment project in the PB 2017 IDE?

Regards ... Chris

Comment
i will try it,



Thanks

  1. Irina Tokar
  2. Tuesday, 12 December 2017 08:48 AM
Hi Irena;



  How about René's suggestion about referencing the project object instead in the PBC?



Regards ... Chris

  1. Chris Pollach @Appeon
  2. Tuesday, 12 December 2017 14:39 PM
Hi! I found your post here while struggling to use pbc170.exe myself. I was searching for a logging option which is apparently the source of your problem (/log is not supported). What I found is that you can just run this without the log option, but if you force the output of your command to a file using > you can log your build results like this (just make sure that the LAST parameter is followed by a space before the > : "c:\Program Files (x86)\Appeon\Shared\PowerBuilder\pbc170.exe" /d "D:\PBD Deployment\Main\main.pbt" /o "D:\PBD Deployment\Main\main.exe" /w y /m n /x 32  /v "0111" /fv "111" >C:\mainLog.log



I hope this helps, even though this thread is 4 months old.



 

  1. Damien Dube
  2. Tuesday, 10 April 2018 01:01 AM
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.