1. Matt Balent
  2. PowerBuilder
  3. Friday, 19 May 2023 18:59 PM UTC

I'm seeing this in my Bitbucket repository for one of my datawindow objects:

... stuff here

 procedure="1 execute dbo.p_rmm_GetRefQueueFromID;1 @refQueueID = :refQueueID, @FollowupUserid = :FollowupUserid" arguments=(("refQueueID", string, "劐ц台хᏰц濸х貘шꓸшﵐђ푈х捌е࿬ъ츸х〸х룀ъ론чḸч䴴ъ늸чड़ё덠ъ羐хꔨц뻈ххࠌё粈хх䟜ъх噘ц懀ч㿀х旈цヤъхх侈ц囀ч췰х땜ъ⯸ч恠чц칠хц녘ч걐ъ袀х모цххFollowupUserid"),("FollowupUserid", string, "㰰ш䉈ш໰ъ扨щꒀш℈щⒸъ닐ш쏘ш尨ضṘш獀ш쾘ц뜸ш摘ш钘щ䒨щቨъ簐ш␐ѓ涨ш䧘щ෠ѓ�ё䣔ђ軸ч隐щ뵠ш¤ਧኸщ㾐щ㴨щ憀щ鉐щꫨш㶠щ럘ш䤸щ㗐ш䢘шꅄш옌ш風ш㨨ш鉸щ怠ш錨ض㾠ъᏸѓ佨ш")) )

... more stuff here

PB 2019 v2728

Accepted Answer
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Thursday, 6 June 2024 02:03 AM UTC
  2. PowerBuilder
  3. # Permalink
It's an encoding issue. Somewhere your encoding is not correct format so Windows is interpreting it as this gibberish double-byte characters.
Comment
There are no comments made yet.
John Fauss Accepted Answer Pending Moderation
  1. Friday, 19 May 2023 19:49 PM UTC
  2. PowerBuilder
  3. # 1

Hi, Matt - 

If you look at the version number in the first line of the exported source, is it less than 10? It sounds from your description that the source is in ANSI and is being read in Unicode 16LE.

Best regards, John

Comment
  1. Matt Balent
  2. Friday, 19 May 2023 19:56 PM UTC
Newly created in PB 2019

From the "View Source" within PB:

release 19;

...

and the Chinese characters I've mentioned...

  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.