1. Lemuel Bacli
  2. PowerServer
  3. Tuesday, 5 October 2021 09:08 AM UTC

Hi Appeon, 

 

It's been my 3rd time reinstalling powerserver on my server and every time I always encounter this error: 

 

It's getting frustrating because all the fixes that I know has been applied to this server to no avail. 

I gave IIS_IUSRS full access and also my account - still it fails to connect. 

I want to know what might be the cause of this error? Im publishing to a prod server and cant modify the server like what i did with the past servers.

 

Thank you all for the inputs

Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Friday, 8 October 2021 01:35 AM UTC
  2. PowerServer
  3. # 1

Hi Lamuel,

Please try using the domain name instead of the IP address and please make sure the domain name matches the certificate.

If there is still the issue, please provide the information below for us for more study, thanks.

1. The PowerServer version on your test server.
2. The PowerServer version on your prod server.
3. The Toolkit version you test with the test server.
4. The Toolkit version you test with the prod server.
5. Dose the http port work well?
6. Access the HTTPS connection via domain name on Toolkit machine to see if any error.

Regards,
ZhaoKai

Comment
There are no comments made yet.
Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 6 October 2021 00:16 AM UTC
  2. PowerServer
  3. # 2

Hi Lamuel,

The default https port is 443 but not 80, please specify port 443 in Toolkit, and please make sure there is a valid certificate on IIS. Or please use connection method 'Http' in Toolkit.

Regards,
ZhaoKai

Comment
  1. Lemuel Bacli
  2. Wednesday, 6 October 2021 03:15 AM UTC
Hi Zhao Kai,



I have done this, changed the port to 443 and still get the failure to connect to powerserver. We have used the same certificate with one of the test server and it works. The prod server is the problem...



What might the cause of this error 02012?



thanks!
  1. Helpful
  1. Miguel Leeuwe
  2. Wednesday, 6 October 2021 09:15 AM UTC
Maybe the port 443 has to be opened in the firewall.
  1. Helpful
There are no comments made yet.
Lemuel Bacli Accepted Answer Pending Moderation
  1. Tuesday, 5 October 2021 23:11 PM UTC
  2. PowerServer
  3. # 3

Hi Chris,

 

Is there any need for AEM configuration for this approach? 

 

Thanks!

Comment
  1. Lemuel Bacli
  2. Tuesday, 5 October 2021 23:57 PM UTC
I have checked what you told me. the catch is that, it only packages application that has been previously deployed. So the old settings for that application will apply, even the old PS settings?
  1. Helpful
  1. Chris Pollach @Appeon
  2. Wednesday, 6 October 2021 00:07 AM UTC
That's the way most developers work with a local IIS for their unit testing and then packaging the app from there (or a build machine) over to QA, SysTest, Acceptance Test, etc environments ... then finally into production. That way you have a "controlled" app snapshot that is consistent across environments.
  1. Helpful
  1. Lemuel Bacli
  2. Wednesday, 6 October 2021 00:10 AM UTC
The dilemma now is, i have separate PS for testing and for Prod. Would that yield an error?



Thank you Chris for answering my questions
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 5 October 2021 14:20 PM UTC
  2. PowerServer
  3. # 4

Hi Lemuel;

  FWIW: I would suggest using the "Package" feature on the PS Tool-kit's toolbar and create an installable package for your PS Application. Then run that MSI on the target IIS server.  HTH

Output:

 

Regards ... Chris

Comment
There are no comments made yet.
Lemuel Bacli Accepted Answer Pending Moderation
  1. Tuesday, 5 October 2021 13:01 PM UTC
  2. PowerServer
  3. # 5

Tried it but still the same output:

 

what else should i do?

Comment
There are no comments made yet.
Marco Meoni Accepted Answer Pending Moderation
  1. Tuesday, 5 October 2021 10:04 AM UTC
  2. PowerServer
  3. # 6

Hi Lamuel,

please also post your the toolkit window.

However, the error shows you have configured http (not https) and the IP address (not the hostname).

Please use them when testing from the browser.

Best,

.m

 

Comment
There are no comments made yet.
Lemuel Bacli Accepted Answer Pending Moderation
  1. Tuesday, 5 October 2021 09:54 AM UTC
  2. PowerServer
  3. # 7

 

Hi Marco,
1) Yes that is correct
2) Im able to access the AEM with no errors: