1. Douglas Ross
  2. PowerBuilder
  3. Monday, 31 January 2022 19:59 PM UTC

I am trying to do a Git Push for one object in my pbl's.  This fails so I went to the Workspace's Source Control Properties to try to re-type the password,
The password hasn't changed since the last time I Pushed but - I give it a try.
"Cannot connect to the repository. Please make sure you have specified the correct user ID, and password.

I can go directly to the repository and use my user ID and password. It hasn't changed and it lets me in.

Powerbuilder 2019 R3, build 2703

I've tried a new directory for the workspace and trying to pull the whole thing down using the menu:  File/ "Connect to Workspace" option but that gives a login error - same problem, different wording:  "Failed to perform the specified operation. Please make sure you can connetc to the server repository."

And if I try to change the connect criteria, it defaults back to the last working one after the error.

Any idea why I can connect to the repository outside or PB but not inside?

Thank you,

Accepted Answer
Douglas Ross Accepted Answer Pending Moderation
  1. Monday, 7 February 2022 11:43 AM UTC
  2. PowerBuilder
  3. # Permalink
Thanks Chris, I found that in my ".Git Class" I accidently set up a proxy. So Google told me how to remove this proxy setting : git config --global --unset https.proxy git config --global --unset http.proxy After running those 2 lines in .Git Bash, I'm back to normal. Thank you for you time and help
  1. Chris Pollach @Appeon
  2. Monday, 7 February 2022 13:42 PM UTC
Hi Doug ... Thanks for the feedback on how you fixed your GIT issue. I'm sure that this will come in handy for others in the same possible situation. This is awesome news!

Regards ... Chris
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 31 January 2022 20:05 PM UTC
  2. PowerBuilder
  3. # 1

Hi Doug;

   Have you tried updating your Git Client software recently? The PB IDE will use that to communicate to the repository server.

Regards ... Chris

  1. Chris Pollach @Appeon
  2. Monday, 31 January 2022 21:12 PM UTC
Can you try adding another PB project - say just a simple test case - to see if your current credentials are still accepted?
  1. Helpful
  1. Chris Pollach @Appeon
  2. Tuesday, 1 February 2022 17:59 PM UTC
That's great news Doug! You are most welcome. Thanks for sharing. ;-)
  1. Helpful
  1. Armeen Mazda @Appeon
  2. Tuesday, 1 February 2022 19:02 PM UTC
Please mark as resolved.
  1. Helpful 1
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.