1. Tim Bruce
  2. PowerBuilder
  3. Monday, 27 September 2021 17:14 PM UTC



I am using the BUILT IN TX TEXT CONTROL and I need to add data from the database.  It seems to work ok until I add a column twice.  


Take for instance if I had the following scenario


Test text



In this case the second {CLIENT_NAME} is not displayed but rather the value in {STREET_ADDRESS} is displayed twice.


If I add another  {CLIENT_NAME} like this


Test text



then I get 2 street addresses and then value from client name.




Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 27 September 2021 19:52 PM UTC
  2. PowerBuilder
  3. # 1

Hi Tim;

  Can you tell us ...

  • The version of MS-Windows that you are using?
  • The version & build of PB that you are using?
  • The version of the TX control that you are using (as per the App Painter)?

Regards ... Chris

  1. Chris Pollach @Appeon
  2. Tuesday, 28 September 2021 16:27 PM UTC
If your using Appeon PB 2019 then you could be using the "built-in" TX control v15. If your on PB2019R3 or PB2021, then you could also use (try) v28 of the built-in TX control.
  1. Helpful
  1. Armeen Mazda @Appeon
  2. Tuesday, 28 September 2021 16:49 PM UTC
Hi Tim, You should be using Built-in TX TextControl. Don't mess around with the other options because they are all discontinued. If you still have problems when using Built-in TX TextControl option, please provide reproducible test case and open a support ticket: https://www.appeon.com/standardsupport/newbug
  1. Helpful
  1. Tim Bruce
  2. Tuesday, 28 September 2021 17:31 PM UTC
ok thanks. I may have to do that as I am using the built in TX control
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.
We use cookies which are necessary for the proper functioning of our websites. We also use cookies to analyze our traffic, improve your experience and provide social media features. If you continue to use this site, you consent to our use of cookies.