1. Haihong Yang
  2. PowerBuilder
  3. Saturday, 15 May 2021 20:01 PM UTC

Hi,

I try to use PowerBuilder compiler to build executable using Deploy in PowerBuilder IDE. My PowerBuilder IDE is 2019 R3 Build 2670. After creating deploy parameter file I can build executable in IDE using deploy. Then I copy the parameters from deploy window, and using command line PBC190.exe to build the executable. The executable can not build pbr file into executable. The application cannot display image. Does anybody know what is the issue?      

Thank

  

Who is viewing this page
René Ullrich Accepted Answer Pending Moderation
  1. Monday, 17 May 2021 07:30 AM UTC
  2. PowerBuilder
  3. # 1

Hi Haihong,

do you use PBR files only for exe or also PBR file for PBDs?

PBC190.exe can only handle one PBR file (for exe) but not multiple PBR files (for PBDs).

 

Comment
There are no comments made yet.
Ken Guo @Appeon Accepted Answer Pending Moderation
  1. Monday, 17 May 2021 07:24 AM UTC
  2. PowerBuilder
  3. # 2

Hi Haihong,

 

I didn’t reproduce the issue you mentioned in my local verification. If you do not use PBC, but instead deploy it directly in PB IDE, does it work?

 

If deploying through PB IDE works but deploying through PBC doesn’t work, can you build a small case and see if it has the same issue? If it does, I suggest that you submit a ticket to the Appeon Support system and upload the small case there.

 

Regards,

Ken

Comment
There are no comments made yet.
Haihong Yang Accepted Answer Pending Moderation
  1. Monday, 17 May 2021 01:58 AM UTC
  2. PowerBuilder
  3. # 3

Marco,

I do use /r option. The parameter copied exactly from the deploy setup file.

 

Thanks

Haihong

Comment
There are no comments made yet.
Marco Meoni Accepted Answer Pending Moderation
  1. Sunday, 16 May 2021 15:58 PM UTC
  2. PowerBuilder
  3. # 4

Hi Haihong,

did you include /r option and PBR path in the pbc190.exe parameters? For example:

pbc190 .... /r "C:\fullpath\app.pbr"

 

Best,

.m

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.