1. Tracy Lamb
  2. PowerBuilder
  3. Sunday, 20 March 2022 21:19 PM UTC

Everything was going OK... got my app migrated and a few things debugged.  I'm using the latest PFC files.  Was trying to debug an error when running the app from with the IDE, I decided to just copy my old pfc extension libraries and re-migrate. 

The error I was initially trying to debug is a Null Object error in the SystemError event of the application object.  The offending (only) line:

gnv_app.Event pfc_SystemError()

Things went downhill from there. Long story short, I'm now getting an error migrating the app.  The error is:

Assertion Failure
missing case in obj_get_pcode_stack_effects (twice)
File: rtengine.cpp

Then PB2021 crashes.

I tried dropping the entire target and recreating, no luck.  I also did a complete computer reboot, no luck. Same result every time I try to migrate.

Need some help here!





Accepted Answer
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Sunday, 20 March 2022 21:38 PM UTC
  2. PowerBuilder
  3. # Permalink

Hi Tracy;

   Sounds like you might have "suspect" PowerScript code in your old PFE layer. I would return to the lastest PFC/PFE layer with your PB App code. Then re-migrate & do a full build. If that brings the App back to a runnable condition, then I mould merge the old PFE objects "as needed" but fully check the code first before replacing the current PFE layered object.

Regards ...  Chris

  1. Tracy Lamb
  2. Tuesday, 22 March 2022 15:42 PM UTC
Thank you Chris. I started from scratch (again) with the current PFC/PFE files. I had to export a few PFE layer objects from PB 2019 app. I took care to do it one at a time... took a while! Now time to run and debug... I'm immediately running into issues with the login window... will post another question if I can't figure it out.
  1. Helpful
  1. Chris Pollach @Appeon
  2. Tuesday, 22 March 2022 18:52 PM UTC
Thanks for the feedback! Yes, opening a new thread for another issue would be better for people to follow & focus on.
  1. Helpful
There are no comments made yet.

There are replies in this question but you are not allowed to view the replies from this question.