1. Alan Rice
  2. PowerBuilder
  3. Friday, 9 March 2018 17:26 PM UTC

Android Custom Workspace Failing to Auto Update


I am having an issue with the Workspace Auto-Upgrade with Android (have not tested with iOS yet). I've tried a few different settings with no luck. I upload the custom Workspace APK to the AEM site without issue and also download it from there by using the URL or opening the URL via the QR Code. It installs fine on the device.

If I add an updated version of the workspace to the AEM it does not automatically update on the device. Is there any logs or some way for me to figure out why this isn't happening? If I update the app by hand by re-downloading the APK from the URL I do get the new version. It updates the existing app as expected i.e. it doesn't add a second version of the app.

In the AEM control panel there is only ever one entry for the App as well. I've incremented the build number in the Package settings and also in the APK name but still no luck.

Below are my current settings, can anyone point me in the right direction? At the minute its just not auto-updating but I don't have any error codes or much else to go on.

Package Settings

I've updated the App version Code and App Version name between updates here. I am also updating the Workspace Banner Template to see if the app updates automatically. Just some colour changes etc.


Package APK Build

I have tried various names for the APK before uploading it to the AEM. I've used the generated file name and not changed it between versions. I've also tried changing the 00 to 01 or 02 etc. but no luck.



In the AEM I can see that build number and App ID look to be correct. They pick it up correctly from the APK filename. 
(I was names other than Client work space and com.mydomain.clientworkspace but have changed it here to be anonymous but my versions were in the same format)


Alfredo Aldama Accepted Answer Pending Moderation
  1. Friday, 9 March 2018 18:07 PM UTC
  2. PowerBuilder
  3. # 1

In my case something similar happened to me, I did the configuration with the assistant and it worked, compare the settings and note that I had omitted the port in my previous configuration, also check my firewall and change the configuration to lower.

  1. Alan Rice
  2. Monday, 12 March 2018 09:55 AM UTC
Not sure what you mean here. The QR code has the port number in it for downloading. Again this downloads without issue, so I would assume any firewall related options are ok.

The problem is that the Auto-Update/Upgrade feature fails to update the custom Workspace automatically. i.e. when I make a new build of the workspace with custom settings it doesn't update the workspace on the app without me having to click run the update by hand.


  1. Helpful
There are no comments made yet.
Govinda Lopez @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 13 March 2018 18:34 PM UTC
  2. PowerBuilder
  3. # 2

Hi Alan,


Appeon Workspace can check for the updated version when it connects with the PowerServer, and when updated version is detected the end user will be prompted to install the updated version. To use this feature, set the Check for Workspace Update option to On. 

Check for workspace updates Note: this feature is for upgrading the Appeon Workspace only, not the application files. The application files will be automatically updated without notification when newer version is available on the PowerServer. 

I would also recommend that your AEM setting include the IP name or domain name address of your server with the port number. That is because, by default, the settings are like this: http://localhost/myapp so you would need to change it to something like this: http://mydomain.com:80/myapp or



There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.