1. Konstantin Goldobin
  2. PowerBuilder
  3. Thursday, 08 February 2018

Hello,

I downloaded 9.0.1689.00.apk to my Android emulator, but when I tap it Android says "Can't open file". Installation from unknown sources is enabled in Android settings. What am I missing?

BTW, is there a way to make an Android emulator understand "localhost"? Since both PowerServer mobile and the emulator are running on the same machine, it would be much more convenient...

Thank you!

Roland Smith Accepted Answer Pending Moderation
0
Votes
Undo

I have done some Android development with another development tool and it has a small app you install on the device that the IDE communicates with. This allows the IDE to install applications to the device directly and to do remote debugging. It also becomes a FTP server so I can use any Windows FTP client to copy files back and forth. This also comes in handy when I want to transfer pictures as my phone didn't come with USB cord.

It would be really great if the PowerBuilder IDE could do the same.

Comment
There are no comments made yet.
  1. Thursday, 8 February 2018
  2. PowerBuilder
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Konstantin;

1)  For the Android emulator or even the real Android O/S, you need to set the operating system to "accept unknown sources" before the APK will install. Yo can see that setting under the "Settings" => "Security" tab, as follows:

2) For the "localhost" setting - this is an MS-Windows convention and something that Android does not understand. You still need to use either a proper DNS name or an IP addresses of the PowerServer in order to access.

HTH

Regards ... Chris

Comment
Hello Chris,



Sorry for not being clear enough! When I wrote " Installation from unknown sources is enabled in Android settings" I meant that  "unknown sources" setting is enabled.



As for localhost, I googled that 10.0.2.2 should work and will try it tomorrow.



Best regards,

Konstantin

  1. Konstantin Goldobin
  2. Thursday, 8 February 2018
There are no comments made yet.
  1. Thursday, 8 February 2018
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.