1. José Arturo Garcia
  2. PowerBuilder
  3. Monday, 07 October 2019

He utilizado durante muchos años y versiones Powerbuilder, la última versión a la que he tenido acceso ha sido la 12.5

En todas hemos trabajado normalmente con Postgresql. Desde la versión 9 a las 12.5, sin problema alguno.

Pero ahora al querer probar Powerbuilder 2019 y hacer la conexión con la BD Postgres a través de Odbc, resulta que no muestra el esquema al que pertenecen las tablas.

Para nosotros es importante el esquema, debido a que tenemos varias tablas con el mismo nombre en diferentes esquemas. Pero al hacer la conexión, solo permite ver, las que pertenecen al esquema public, y las que no pertenecen al esquema public, aunque las muestra, al querer accesarlas marca que la tabla no tiene columnas, o que el formato de la tabla es inválido.

¿Como se puede solucionar éste problema? ¿Existe algún parche de powerbuilder 2019 para ello?

Nota: el mismo problema se presentó con Powerbuilder 2017, porque que decidimos esperar a que se corrigiera éste error, pero parece ser que no se hizo.

 

Who is viewing this page
Govinda Lopez Accepted Answer Pending Moderation
0
Votes
Undo

Buen día José:

 

¿Me puedes decir qué versión de PostgreSql utilizas? 

 

 

Saludos,

Comment
Instalaré PostgreSQL 10 como lo sugieres, y haré las pruebas.
  1. José Arturo Garcia
  2. Wednesday, 9 October 2019
Creo que 10 tiene el mismo comportamiento.
  1. Miguel Leeuwe
  2. Friday, 11 October 2019
Hice mis pruebas con PostreSQL 10. Efectivamente, sucede lo mismo. No separa los esquemas.
  1. José Arturo Garcia
  2. Friday, 11 October 2019
There are no comments made yet.
  1. Monday, 7 October 2019
  2. PowerBuilder
  3. # 1
José Arturo Garcia Accepted Answer Pending Moderation
0
Votes
Undo

Desconozco si existe algún ticket para solucionar ese inconveniente. El hecho es que nosotros hemos trabajado con postgres desde powerbuilder 9 hasta el 12.5 y no hemos tenido ese problema. Adjunto al presente un ejemplo de cómo lo muestra PB12.5 y como lo muestra PB2019. 

Se puede observar claramente como con PB12.5 se muestra el esquema al que pertenece cada tabla, mientras que con PB2019 no sucede así.

Gracias, saludos.

Attachments (1)
Comment
Hola Jose;

¿Ha probado uno de estos controladores ODBC PostgreSQL que está utilizando con PB 12.5 con PB2017 o PB2019 para ver si funciona bien con la función "Esquema".

Saludos ... Chris
  1. Chris Pollach
  2. Tuesday, 8 October 2019
Sí, he probado con los que actualmente trabaja PB12.5 y he descargado varios controladores para hacer la prueba, y nada.
  1. José Arturo Garcia
  2. Wednesday, 9 October 2019
Qué decepción ... pensé que el viejo controlador ODBC que usabas con PB12.5 podría funcionar hasta que Appeon pueda solucionar el problema en su controlador ODBC PB2017 / 2019. Ahora me gustaría sugerirle que abra un "ticket de soporte" para este problema para que nuestro equipo de ingeniería de Appeon pueda involucrarse con este problema.
  1. Chris Pollach
  2. Wednesday, 9 October 2019
There are no comments made yet.
  1. Monday, 7 October 2019
  2. PowerBuilder
  3. # 2
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hola José ;

   PB actualmente admite el "propietario" de una función de tabla pero no el aspecto "Esquema". Revisé todos los tickets de PostGreSQL pero no pude encontrar una solicitud para la función "Esquema". ¿Sabes con qué número de ticket de soporte podría haberse creado la solicitud de mejora de Schema?

Saludos ... Chris

Comment
There are no comments made yet.
  1. Monday, 7 October 2019
  2. PowerBuilder
  3. # 3
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.