1. Vladimir Khais
  2. Beta Testing
  3. Monday, 4 March 2019 21:38 PM UTC

Greetings all.

Working with BETA, I make a build as usual, and install it on standalone machine, got all run-times files out of the package right in the installed directory.

Getting ADO.Net connection error please see attached. Did check .net looks good, please see attached.

Did try to install build on the development machine with BETA, look good, NO ADO.Net connection error.

Did try to install build on the development machine with 2017 R2/R3, ADO.Net connection error.

I also did try to include into the runtime .msi every single option for dll's and unzip them into our app install directory ... still no good

Can someone tell me what am i missing please?

Help will be greatly appreciated.

Thank you

Sincerely

Vlad

Here is the tread we did read and make a post:

https://community.appeon.com/index.php/qna/q-a/ado-net-connection

Here is the list of files we are deploying:

APACHE_LICENSE.TXT
libcrypto-1_1.dll
libjcc.dll
libjtml.dll
libjutils.dll
libsybunic.dll
nlwnsck.dll
pbacc180.dll
pbado180.dll
pbcompression180.dll
pbcomrt180.dll
pbcrypt180.dll
PBDOM180.pbx
pbdpl180.dll
pbdwe180.dll
pbDWExcel12Interop180.dll
pbdwr180.pbd
pbhttpclient180.dll
pbjag180.dll
pbjson180.dll
pbjvm180.dll
pbjwt180.dll
pboauth180.dll
pbPDF180.dll
pbrestclient180.dll
pbshr180.dll
pbsysfunc180.dll
pbtheme180.dll
pbtra180.dll
pbtrs180.dll
pbUIS180.dll
pbvm180.dll
pbXerces180.dll
Sybase.PowerBuilder.Db.dll
Sybase.PowerBuilder.DbExt.dll
xerces-c_2_8.dll
xerces-depdom_2_8.dll

 

Attachments (2)
Mark Lee @Appeon Accepted Answer Pending Moderation
  1. Thursday, 7 March 2019 08:03 AM UTC
  2. Beta Testing
  3. # 1

Hi Vlad,

 

1. Please refer to the following link:

https://www.appeon.com/support/documents/appeon_online_help/pb2019/application_techniques/ch35s03.html 

https://www.appeon.com/support/documents/appeon_online_help/pb2019/application_techniques/ch35s05.html#ADO_NET_database 

 

2. Please add the following DLLs in the list of files you are deploying:

    atl100.dll

    msvcr100.dll

    msvcp100.dll

    pbado180.dll

    pbrth180.dll                                (default path: C:\Program Files (x86)\Appeon\Shared\PowerBuilder)

    sybase.PowerBuilder.Db.dll           (default path: C:\Program Files (x86)\Appeon\PowerBuilder 18.0\DotNET\bin)

    sybase.PowerBuilder.DbExt.dll       (default path: C:\Program Files (x86)\Appeon\PowerBuilder 18.0\DotNET\bin)

    Sybase.PowerBuilder.DataSource.Sharing.dll   

                                                     (default path: C:\Program Files (x86)\Appeon\PowerBuilder 18.0\DotNET\bin)

 

If it still doesn’t resolve the issue, we suggest that you include all the DLLs from the runtime msi package into this folder (include my suggest add these dlls) and see if it resolves the issue.

 

Regards,

Mark Lee

 

Comment
  1. Vladimir Khais
  2. Thursday, 7 March 2019 21:22 PM UTC
Hi Mark.

Thank you.

I tracked down that problem was 2 missing .dll's: pbrth180.dll and Sybase.PowerBuilder.DataSource.Sharing.dll



Error is gone.

Thank you again.



BTW, as Chris advise, i installed BETA 2 and run into the same problem, to fix it, i add same missing .dll's, only this time it was: pbrth190.dll and Sybase.PowerBuilder.DataSource.Sharing.dll



There is also a bigger problem with BETA 2 - Themes is NOT WORKING anymore.



Can you help?



Thx

  1. Helpful
  1. Chris Pollach @Appeon
  2. Thursday, 7 March 2019 21:52 PM UTC
Hi Vlad;

1) Please open a Support Case for the missing ADO.Net DLL's.

2) Themes are working OK for me.

Note: you need to copy the "Theme190" folder (and all of its contents) to the PB App's EXE's deployment folder in Beta#2 for the themes to work.

HTH

Regards ... Chris

  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 6 March 2019 20:40 PM UTC
  2. Beta Testing
  3. # 2

Hi Vlad;

   FWIW:  I see that you have PBxxxx180.DLL's, which indicates that you are using the old Beta#1 of PB2019. That beta program has now closed in February, 2019. Please continue to try out features like ADO.Net in PB2019 Beta#2. FYI:  https://www.appeon.com/developers/pb-2019-beta.html

  If you have the same ADO connectivity issues in Beta#2, please report them here: https://www.appeon.com/standardsupport/newbug

Regards ... Chris

Comment
  1. Vladimir Khais
  2. Thursday, 7 March 2019 21:28 PM UTC
Hi Chris.

Thank you for pointing out.

Same problem out the box, but i already reply to Mark, missing runtimes are: pbrth190.dll and Sybase.PowerBuilder.DataSource.Sharing.dll



Chris, if you have beta 2 installed, can you check if Themes are working for you please.

They are not working for me (beta 1 is fine) unless i am missing something or/and doing something wrong.



Greatly appreciated.

Sincerely

Vlad
  1. Helpful
There are no comments made yet.
Vladimir Khais Accepted Answer Pending Moderation
  1. Wednesday, 6 March 2019 16:41 PM UTC
  2. Beta Testing
  3. # 3

Hi All.

Someone? Anyone? Am i only one with this problem?

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.