1. Andreas Mykonios
  2. PowerBuilder
  3. Monday, 11 September 2017 09:15 AM UTC

Hi to everyone.

I was testing the autocompile in powerbuilder 2017. I've seen also a bug submitted by Bruce Armstrong 14 July, 2017.

One thing that isn't really clear to me is if the DEBUG symbol is enabled or not. Nothing mentioned in the documentation. Also there seems to be a /h parameter witch should show the help for pbc170.exe. But it only shows the version.

C:\Users\Majg>pbc170 /h
Version 1.0

Now, I have a project with lot of targets where the difference between the targets is in some pbls that differentiate the project (and lot of pbls are common). The different pbl's inherit from some of the common pbls, so those targets are something like clones, but they are not totally identical. In those targets I use imagXpress to display images (active-x). The application is an mdi application and has a menu. Since the begining of that project (I started it in 2004) I was getting the following warning when deploying any of the targets:

 ---------- Compiler: Warnings   (11:12:20 πμ)
iidindex.pbl(w_ind_saveimageselection).ole_notateselection.8: Information C0149: The identifier 'menuid' conflicts with an existing property with this name in the parent class. The new definition of 'menuid' will take precedence and the prior value will be ignored until this version of 'menuid' goes out of scope.
iidindex.pbl(w_ind_saveimageselection).ole_notateselection.15: Information C0149: The identifier 'menuid' conflicts with an existing property with this name in the parent class. The new definition of 'menuid' will take precedence and the prior value will be ignored until this version of 'menuid' goes out of scope.

This is a warning and the compilation succeeds.

Now in some cases, when I deploy a specific target using pbc170, the pbds are created, but not the exe... Other targets works fine (but have not checked all of them).

Has anyone else seen anything similar?

Andreas.

Accepted Answer
Miguel Leeuwee Accepted Answer Pending Moderation
  1. Wednesday, 13 September 2017 02:31 AM UTC
  2. PowerBuilder
  3. # Permalink
0
Votes
Undo

Hi, 

Only as a comment on the warning you get when compiling the activeX and if you want to get rid of it.

Something similar happened to me when using the Olecontrol of the "Microsoft Webbrowser ActiveX": It has variables "text" and "cancel" that produce similar warnings as you are getting.

My way to get rid of it, was to create a new "custom visual object", paste the olecontrol on that new custom object, save it and afterwards edit the source code.

I replaced all "text" which were causing warnings with "is_text" and all "cancel" with "ab_cancel". After that, instead of having the olecontrol on each of my windows, I now replaced those with the newly made custom visual object.

In my case I had to create some functions and events on that custom control, since before, my windows were interacting directly with the control, and now had to access that control inside of an object.

For the webbrowser activex, it's not possible to create a "standard visual" object and then choose "olecontrol" since the webbrowser doesn't show in the list of olecontrols that you get afterwards. That's why I had to use a custom object, but maybe in your case, you are lucky and the activex that you are using does show in the list when creaing a standard visaul object, choose olecontrol and the check the list you see at that point. If that would be the case, your windows can still directly interact with the ole control. The only thing you would have to change would be the name of the olecontrol by editing the window's source code or pasting the new one.

HIH,

MiguelL

Comment
sorry for the spelling errors, time to clean my keyboard :)

  1. Miguel Leeuwee
  2. Wednesday, 13 September 2017 02:33 AM UTC
Thank you for the reply.



I will do some testing when I have more free time.

  1. Andreas Mykonios
  2. Tuesday, 26 September 2017 08:13 AM UTC
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 11 September 2017 13:13 PM UTC
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi Andreas;

   Please create a support ticket for these issues around the PBC.

Regards  ... Chris

Comment
Thank you Chris.



I would report a bug, if I have the same problem to all targets in my workspace. But this isn't the case. The exe isn't created for one target, right now. And this target deploys succesfully within the IDE. I try to find why this doesn't happen with pbc.



Andreas.

  1. Andreas Mykonios
  2. Tuesday, 26 September 2017 08:16 AM UTC
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.