1. John Brown
  2. PowerBuilder
  3. Monday, 11 January 2021 14:55 PM UTC

Longtime Appeon user / first time posting.  I did see another post in regards to Informix but didn't seem to match what I needed.

In the past, I've used Appeon with Sybase and Oracle without any problems.

My current client company is using Informix and I'm unable to get 32 bit deployment to work.

A compiled EXE works on my PC, but I have the IDE on my machine.  In the past, with the other database environments, I didn't run into these issues, so I'm struggling with trying to find a resolution.


Database : IBM Informix Dynamic Server Version 12.10.FC7W1

SDK Client :

OS : Windows 10.


I created the exe and gave the tester the folder with all the necessary items.  They put it on their machine and we get 

"DBMS ODBC not supported in your current installation."  They have the database client installed, cause they're able to connect via other applications, including PowerBuilder 12.6.

I made sure that that PB Informix support DLLs are included.  We tried with the runtime packager and we actually had to move the files for them to be recognized.  Initially, it was telling us that specific support DLLs weren't found.  Once we relocated the DLLs, everything worked fine ... other than the DBMS ODBC message we're getting.


Thanks for any guidance.

- John

Olan Knight Accepted Answer Pending Moderation
  1. Thursday, 3 June 2021 13:12 PM UTC
  2. PowerBuilder
  3. # 1

John, can you please mark this thread as RESOLVED?

Thank you!

There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 11 January 2021 18:06 PM UTC
  2. PowerBuilder
  3. # 2

Hi John;

  This certainly sounds like a "deployment" / run-time issue. Please review the deployment requirements in the PB Help file under the keywords "runtime files" and read/compare carefully what you require vs what you deployed.

  As you stated, the PB 12.6 version of the App is working ... so please check to make sure that your PB2019 Rx is using the same SQLCA settings as the other PB 12.6 Apps. 

  Normally only way that the "unsupported DBMS" message is encountered is if you do not distribute the PB "DB Interface" driver. If your using the native Informix DB driver, then the DLL to look for is PBI10190.dll. If you are connecting via ODBC, then the DB Interface will be PBODB190.dll. Again, check your PB 12.6 Apps as the DLL's are the same, just the version numbers are different (PBI10126 and PBODB126) in those DLL's vs PB2019.

Regards ... Chris


  1. John Brown
  2. Wednesday, 2 June 2021 18:53 PM UTC
Oh. I thought it had to be the PBODB19.dll

I'll try with the PBODB.dll and see if that resolves it. ( granted, I'm thinking that file will be there ... but I'll double-check )

  1. Helpful
  1. John Brown
  2. Wednesday, 2 June 2021 19:11 PM UTC
@Chris - That was the issue! I never would have caught that! Thank you!
  1. Helpful
  1. Chris Pollach @Appeon
  2. Wednesday, 2 June 2021 19:18 PM UTC
That is "awesome" news John!

Don't forget to hug a DataWindow today. ;-)
  1. Helpful
There are no comments made yet.
Govinda Lopez @Appeon Accepted Answer Pending Moderation
  1. Monday, 11 January 2021 16:58 PM UTC
  2. PowerBuilder
  3. # 3

Hi John,


This sounds as a probable bug. Please open a support ticket including the version and build numbers of your PowerBuilder and Informix installations.




  1. John Brown
  2. Monday, 11 January 2021 18:35 PM UTC
Govinda - Thanks for the quick response. I have great news. I was able to resolve this issue. We have 2 PowerBuilder applications ... one big one that is current, and one that is small and very old and outdated. I was working with the very old one. I was able to trace the source of the issue to configuration, INI, and SQLCA in the code. After tweaking some things, I finally was able to resolve connection issues! Thanks again!
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.