1. Kevin Ridley
  2. PowerBuilder
  3. Tuesday, 8 January 2019 16:45 PM

We have a super weird issue with a browser control.  We have an external vendor supplied .NET 1 page app that we host and call from PB 12.5.2 (build 5609).  The control sits on a response window.  We've been in prod for almost a year with great success.  The vendor has now supplied a 2nd .NET 1 page app with a separate URL.  The new app has a dropdown on it.  In the IDE on a win7 machine, the dropdown works as expected, expanding and allowing selection of a value, but in the EXE on both win7 and win10, the dropdown will open but you cannot select a value.  Here's the very weird part, in the EXE on both win7 and win10, if you right click in the browser control and open the properties window and then click the dropdown, it works as expected, allowing selection of a value.  Has anyone else seen craziness like this?  I tried the registry setting to change compatibility mode from Yuri Denshchik's video (to IE11) but that didn't work either.

Miguel Leeuwe Accepted Answer Pending Moderation
  1. Friday, 20 November 2020 08:09 AM
  2. PowerBuilder
  3. # 1
1
Votes
Undo

Hi,

Yes this seems very weird. Maybe it's a wild guess, but would it be possible that when running from the IDE, the 32 bit version of IE is being run and when running the EXE, for some reason the 64 bit version of IE ?

If that would turn out to be the case, then your can force the use of the 32 bit browser by importing this registry setting:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"TabProcGrowth"=dword:00000001

 

Comment
Hi Miguel ... that registry setting would be for PowerServer Web Apps. ;-)
  1. Chris Pollach @Appeon
  2. Friday, 20 November 2020 15:12 PM
Hi Chris, exactly, that's where I got the idea from (it would also work if you'd run the browser, since it's a windows wide setting)... Anyways I was wrong, as he's using the browser "control" which I suppose only has a 32 bit version anyway.
  1. Miguel Leeuwe
  2. Friday, 20 November 2020 16:14 PM
That was a good suggestion though Miguel. Sometimes, you just never know! ;-)
  1. Chris Pollach @Appeon
  2. Friday, 20 November 2020 18:20 PM
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Thursday, 19 November 2020 22:40 PM
  2. PowerBuilder
  3. # 2
0
Votes
Undo

Do you have the same problem if you use the new Chromium WebBrowser control?  I know you are currently on PB 12.5, but just as a test to see if it is the Internet Explorer browser problem.

Comment
There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Friday, 11 January 2019 15:58 PM
  2. PowerBuilder
  3. # 3
0
Votes
Undo

It sounds to me like the focus is not being set on the DDDW after it has opened, and that clicking the DDDW does not set the focus.

Try setting the focus onto the DDDW in the code after the dddw has been opened.

 

Olan

Comment
Hi Olan, thanks for the reply, but the dropdown is on the webpage, not in PB. This is a .NET app with a dropdown running inside the browser control.
  1. Kevin Ridley
  2. Friday, 11 January 2019 16:10 PM
There are no comments made yet.
Kevin Ridley Accepted Answer Pending Moderation
  1. Wednesday, 9 January 2019 22:01 PM
  2. PowerBuilder
  3. # 4
0
Votes
Undo

Hey Chris,

 Thanks for following up.  There's not really much to see.  The Microsoft Web control takes up the whole page.  The app this is running has a dropdown that will open but does not close.  I'm attaching a screenshot of the relevant area with last names crossed out.  As you can see it opens, and another weird thing, if you just move the mouse it will select more than one until you click (probably not relevant).  When you click it does select, but does not close.  The only way it closes is if you click away from the dropdown, but it doesn't keep the value, just closes with no value selected.

 

If you right click inside the browser and select Properties, the properties widow does open, and only then the dropdown works as expected.  It selects and closes when you click and the value is retained.  But if you close the properties window and try again, you get the original results where it does not select and close.

 

I tried the registry "hack" mentioned in this article:
https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/general-info/ee330730(v=vs.85)#browser_emulation

but not sure if it's possible to determine if it's actually in IE11 mode, or still in 7.

 

Again for clarity, it does, for some reason work in the IDE just not the EXE.

Attachments (1)
Comment
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 9 January 2019 20:52 PM
  2. PowerBuilder
  3. # 5
0
Votes
Undo

Hi Kevin;

    Can you post some screen captures of what you are seeing?

Regards ... Chris

Comment
There are no comments made yet.
Kevin Ridley Accepted Answer Pending Moderation
  1. Wednesday, 9 January 2019 13:17 PM
  2. PowerBuilder
  3. # 6
0
Votes
Undo

Hi Chris,

 I tried Roland's but got the same results.  Just think it's very odd that if the Properties window is open, it works fine but when it's not open the dropdown doesn't select and close, only highlights.  Wondering what's different inside IE when the Properties window is open. 

Comment
Or potentially what's different about the browser control when running in the IDE vs EXE.
  1. Kevin Ridley
  2. Wednesday, 9 January 2019 13:20 PM
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 8 January 2019 18:55 PM
  2. PowerBuilder
  3. # 7
0
Votes
Undo

Hi Kevin;

   There are some "sneaky" compatibility issues that you might need to set in order for IE to behave when embedded as an OLE control in your PB App. Have you tried Roland's embedded web browser code ... http://www.topwizprogramming.com/freecode_webbrowser.html

Regards ... Chris

 

Comment
Hello,

Someone found a solution for this problem ?
  1. François Thibault
  2. Thursday, 19 November 2020 22:22 PM
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.