1. Rick Hedin
  2. PowerBuilder
  3. Wednesday, 14 August 2019

Hi.  I am trying to get a handle on what PB version would be most appropriate.   We were running PB 12.6 on a Windows Server 2008 R2 machine.   We are trying to move our PB 12.6 to a Windows Server 2016 Standard machine. 

The installation of the PB dll's failed on registering the pbjvm126.dll.   Apparently, that's because it wants a higher version of the Microsoft C dll's. 

This sounds like a question about an installation problem, but it's really not.   I'm having trouble getting a handle on what versions of PB are available.  Is there some giant matrix somewhere?   "On a Windows Server 2016 Standard machine, you can have x, y, and z versions of PowerBuilder."   I haven't found the documentation, so far. 

Thanks. 

 

Mariano Collado Accepted Answer Pending Moderation
2
Votes
Undo

Hi Rick,

PowerBuilder versions 12.6 and older are SAP products that have reached End-of-Life and are no longer available.

Appeon develops and distributes PowerBuilder versions 2017 and newer. 

Here is a matrix of all versions, subversions, and builds of Appeon PowerBuilder: https://www.appeon.com/update

All Appeon PowerBuilder versions (PowerBuilder versions 2017 and newer) support the following operating systems:

Supported by PowerBuilder IDE and runtime:

Windows 7 32-bit or 64-bit with SP1 KB3033929

Windows 8.1 32-bit or 64-bit

Windows 10 32-bit or 64-bit (excluding Windows IoT and Windows Embedded Compact)

Supported by PowerBuilder runtime only:

Windows Server 2008 32-bit or 64-bit with SP2

Windows Server 2012 R2

Windows Server 2016

 

Cordially,

Mariano C.

Comment
There are no comments made yet.
  1. Wednesday, 14 August 2019
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.