1. Konstantin Goldobin
  2. PowerBuilder
  3. Friday, 20 August 2021 09:28 AM UTC

Hello,

How can I install the cloud app launcher on the client to a custom folder? The group policy on my laptop blocks running it from the default installation path. Thanks!

K

Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Monday, 23 August 2021 08:09 AM UTC
  2. PowerBuilder
  3. # 1

Hi Konstantin,

Sorry that it is not supported to install cloud app launcher on the client to a custom folder at the moment.

Please try the following workaround to copy the launcher to another folder.
1. Install Cloud App Launcher.
2. Copy Launcher from C:\Users\%windows user%\AppData\Local\Launcher to C:\Launcher.
3. Refer to the attached cloudapp.reg to modify the registry item to reference to C:\Launcher.
4. Refer to the attached CloudAppLauncher_withoutservice.reg to modify the registry item ’Location’ to reference to C:\Launcher and change registry item ’CloudAppHome’ to refer to C:\PBApps.

Then you can run the application via browser, the application files and runtime files will be download to C:\PBApps. You can also start the application via a command like below.
C:\Launcher\CloudAppShell.exe %your application URL%

Regards,
ZhaoKai

Attachments (1)
Comment
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 20 August 2021 12:32 PM UTC
  2. PowerBuilder
  3. # 2

Hi Konstantin;

     Did you configure the CAL to run as a background "Service". If so, it will require local Admin privileges. If you configure the CAL to run "without" a service, it will install under your "user" MS-Windows profile.

Regards ... Chris

Comment
  1. Konstantin Goldobin
  2. Friday, 20 August 2021 13:14 PM UTC
Hi Chris,

Thanks, I know! And this is the problem. Actually, we faced two problems when we were trying this feature. The first one was that running self-extracting archives is blocked by the group policy (so, the launcher is never installed when you click that button on the welcome page). We worked this around by manually unzipping the installer file and running it. The second problem was what I described in the initial post: the installer installed the launcher under the user profile, and running exe from that path is blocked by the group policy.

As a side note, we really could use some kind of a troubleshooting guide from Appeon, because when you do as you were told and nothing happens you don't really know what you can do next.
  1. Helpful
  1. Chris Pollach @Appeon
  2. Friday, 20 August 2021 22:04 PM UTC
Hi Konstantin;

Sounds strange that the GP would block running things under the "user folder. Can you not have your operations team unblock the CAL as a trusted source?

Regards ... Chris
  1. Helpful
  1. Miguel Leeuwe
  2. Saturday, 21 August 2021 17:29 PM UTC
Since the Group Policy-people seem to like to be in full control, just tell them to push the installer through GP. Problem solved.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.
We use cookies which are necessary for the proper functioning of our websites. We also use cookies to analyze our traffic, improve your experience and provide social media features. If you continue to use this site, you consent to our use of cookies.